IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Rating
 
Options
Options
Personal Statement
ktp doesn't have a personal statement currently.
Personal Info
ktp
Advanced Member
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Other Information
Country:: No Information
Statistics
Joined: 16-February 07
Profile Views: 140*
Last Seen: Today, 02:14 AM
Local Time: Sep 15 2008, 04:24 AM
365 posts (0.63 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

ktp

Advanced user

***


Topics
Posts
Files E2T
Comments
Friends
My Content
24 Aug 2008
Read Topic
Multiple KNOPPIX-like distributions on same USB key/HDD
Problem: KNOPPIX-based distributions (KNOPPIX, Damn Small Linux (DSL), Kaella...) all use KNOPPIX directory
and the loop file /KNOPPIX/KNOPPIX. So having all of them on same multi-boot USB key/HDD raises name collision
problem. Some distribution like DSL accepts the variable knoppix_dir/knoppix_name so you can change the default KNOPPIX
directory to DSL for example on your key, avoiding name collision.

But other distributions (e.g. Kaella) seems to ignore those variables. After several searches, it appears that for those distributions, one needs to edit the script linuxrc (embedded in ramdisk minirt.gz) to change different occurences of KNOPPIX_DIR or hard-coded KNOPPIX value.
This works flawlessly. The change procedure is:

Under Linux OS:
CODE
  gunzip minirt.gz
  mkdir /mnt/testmount
  mount -o loop minirt /mnt/testmount
  vi /mnt/testmount/linuxrc
    change KNOPPIX_DIR/KNOPPIX values (several occurrences) to KAELLA for example
  umount /mnt/testmount
  gzip minirt


Then you use the modified minirt.gz as ramdisk.
Following are my working entries in grub4dos menu.lst booting those distributions:

CODE
#
title Damn Small Linux 4.4.4 fb1024x678
find --set-root /DSL/linux24
kernel /DSL/linux24 ramdisk_size=100000 lang=fr init=/etc/init noacpi apm=power-off vga=791 xmodule=fbdev  nomce noapic loglevel=0 quiet BOOT_IMAGE=knoppix knoppix_dir=DSL noeject
initrd /DSL/minirt24.gz

#
title Knoppix 5.3.1 fb1024x768
find --set-root /KNOPPIX/linux531
kernel /KNOPPIX/linux531 ramdisk_size=100000 lang=fr init=/etc/init noacpi apm=power-off vga=791 xmodule=fbdev nomce highres=off libata.atapi_enabled=1 SELINUX_INIT=NO nmi_watchdog=0 loglevel=0 quiet BOOT_IMAGE=knoppix  dma noeject knoppix_dir=KNOPPIX
initrd /KNOPPIX/minirt531.gz

#
title Kaella Knoppix Linux Azur 3.2 fb1024x768 (minirt.gz patched)
find --set-root /KAELLA/linux
kernel /KAELLA/linux ramdisk_size=100000 lang=fr init=/etc/init noacpi apm=power-off vga=791 xmodule=fbdev  nomce loglevel=0 quiet BOOT_IMAGE=knoppix  dma noeject knoppix_dir=KAELLA
initrd /KAELLA/minirt.gz



On my USB HDD (x: = drive letter) I have those directories :
x:\DSL (comes from \KNOPPIX directory from Damn Small Linux iso)
x:\KNOPPIX (comes from \KNOPPIX directory from Knoppix iso)
x:\KAELLA (comes from \KNOPPIX directory from Kaella Knoppix Linux Azur iso)

You have to copy also the ramdisk/kernel (minirt.gz, linux) to corresponding DSL/KNOPPIX/KAELLA directory.
You can adjust parameters like lang=, vga= for keyboard/screen resolution. Refer to isolinux.cfg of each distribution (usually in /boot or /boot/isolinux).


The same technique of editing linuxrc or other scripts inside the ramdisk (initrd.gz, minirt.gz...) could be useful for other dsitributions as well.
12 Aug 2008
Read Topic
Conversion isolinux to grub4dos syntax
Hello to all,

I have a bootable iso using isolinux. I cannot use grub4dos with iso emulation (hd32) to boot from the USB key the iso
due to known conflict with isolinux. So I tried to convert isolinux/syslinux configuration (kernel/ramdisk)
to grub4dos syntax. But the problem is that there is two files for ramdisk!

Original syslinux.cfg:
CODE

default boot
display boot.msg
timeout 250
prompt 1
label boot
  kernel vmlinuz

append rw vga=1 init=/linuxrc initrd=initrd.cgz,scsi.cgz



I place the file vmlinuz, initrd.cgz and scsi.cgz at the root of the USB key.

This does boot, but no scsi drivers loaded:
CODE
find --set-root /vmlinuz
kernel /vmlinuz rw vga=1 init=/linuxrc initrd=/initrd.cgz,/scsi.cgz
initrd /initrd.cgz /scsi.cgz


This does not work, ramdisk file not found:
CODE
find --set-root /vmlinuz
kernel /vmlinuz rw vga=1 init=/linuxrc initrd=/initrd.cgz,/scsi.cgz
initrd /initrd.cgz,/scsi.cgz


Is there a solution for this? Thank you.


Edit:
I d not have a solution for the original problem but a bypass is found.
In fact the mentioned iso comes from http://home.eunet.no/~pnordahl/ntpasswd/ (NT/XP/vista offiline password reset).
There is a diskette image format but it requires additiona drivers (files *.zip) loading which is incompatible with grub4dos diskette emulation (diskette image from USB key). Also all the files surpasses 2.88 MB limit.

The bypass is to use a big floppy format (I used the 11MB format provided by bcdw site), then put the needed files from ISO to the ima diskette file (using WinImage). You need to put with syslinux the correct boot sector. Then using grub4dos to load this big diskette image, it works !
7 Aug 2008
Read Topic
dfsee: Display File System
DFSEE : Display File System
Multiplatform disk and filesystem utility
Analysis, maintenance and recovery
http://www.dfsee.com/

I found this utility by Jan van Wijk (author) very powerful and it is multi-platform ! DOS, Windows, Linux, OS/2, Mac OS X.
29 Apr 2008
Read Topic
OS/2 multibootable recovery recovery CD
An interesting Live CD for OS/2 fans (Warp, eCommStation) :
http://www.geocities.com/bearwindows/os2be.htm

Edit: wow, the author is bearwindows, member of this board and author of vbe driver for Win9x/NT :
http://www.boot-land.net/forums/?showforum=60
29 Apr 2008
Read Topic
Booting Windows 98 SE from external USB hard disk
Hello,

I just tried to install and run Windows 98 SE to/from external USB hard disk. Surprisingly everything works well, no dreaded BSOD 0x7B as with NT/XP/Vista. Thanks to bearwindows's Universal Video driver http://www.boot-land.net/forums/index.php?showforum=60 I am not limited to standard VGA 640x480.

Remained items:
- network card
- NTFS support: this is done with the now free read/write NTFS for Windows 98 from Winternals.
- USB 2.0 support
- service packs
- sound card

There is a great support forum for Win9x at MSFN board.

Question : why Win9x does not have problem (BSOD 0x7B) booting from USB HDD ?
Last Visitors


31 Aug 2008 - 21:46


30 Aug 2008 - 18:44


24 Aug 2008 - 17:35
piotrania


20 Aug 2008 - 18:42


8 Aug 2008 - 8:07

Comments
Nuno Brito
A true expert in the field of boot disks, thanks for your help to this community.
:)
1 May 2008 - 20:50

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 15th September 2008 - 03:24 AM
IPS Driver Error

IPS Driver Error

There appears to be an error with the database.
You can try to refresh the page by clicking here