Hello dear guest!

Boot Land is a community driven pc software site established since 2006 and focused on recovery/backup boot disks, research of Microsoft Windows 2000/XP/2003/Vista/7 install/deployment/lease/antivirus/antispam tools, customizing Microsoft Windows PE administration systems and even learning how to recover computer data from disaster situations!

How about joining our boot disk community? So do it. Life's short!

  - You get free access to our newsletter with all the interesting buzz about boot disks
  - We share publicity revenue with everyone who wishes to participate at the forums
  - Publicity is never, never, never displayed to members (along with many other cool things)
http://boot-land.net/register


river~~

Members

**

Joined: 11-May 09
Profile Views: 2*
Last Seen: 8th January 2010 - 03:55 AM
Local Time: Jun 17 2010, 02:37 AM 34 posts (0.08 per day)

river~~ doesn't have a personal statement currently.

Profile
Personal Photo
Personal Info
Contact Information

 

river~~
Member
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Send Message
Contact Send an Email

Topics
Posts
About Me
Files E2T
Comments
Friends
My Content
14 May 2009
Read Topic
Use of (rd) ?
I'd appreciate some documentation on the use of (rd) in grub4dos.

It comes up as a device, and I assume it is a ramdisk.

The sort of things I'd like to know about it are
  • Is it the place that initrd is loaded to, or is it different?
  • Can we write to it, & if so can an operating system see it?


I did a search for rd and (rd) but nothing came up - if the docs exist somewhere then I just need a link to get me started.

thankks,
River~~
13 May 2009
Read Topic
error in sourceforge wiki
hi, I spotted an error in the sourceforge wiki cdrom instructions

It says first (and correctly)

cdrom --init

followed by (wrongly)

cdrom --hook

this does not work (at least not with v0.4.4) but what *does* work is

map --hook

so the two lines should actually read

CODE
cdrom --init
map --hook


Secondly, I thought I would be helpful & change it - but the create new username function seems to be missing from that wiki. All you get is another chance to log in with an existing username.

If the maintainers want help keeping it up to date, maybe they'd enable new account creation please?

If the wiki-keepers don't want any help, then perhaps someone here has the magic spells to get in and make the correction, please?

regards,
River~~
13 May 2009
Read Topic
map drive image stored on compressed NTFS
When you try to map a floppy disk image that is held on a compressed NTFS drive, the mapping fails with an error message saying that the file is non-contiguous.

The obvious way to fix this is to use memory mapping, but sometimes that is not what you want. Perhaps you want to be able to write to the "drive", and of course if you write to a memory-mapped drive all the changes get lost when you reboot.

The next thing I tried was to de-fragment the drive, to make the file contiguous -- but this does not help when the problem is that the file or folder is compressed, despite the (slightly misleading) error message.

This is what to do.

Before you copy the floppy image to the compressed NTFS drive, right click on the drive in my computer, and untick the compressed tickbox near the bottom left of the properties sheet. You will be asked whether to apply this change to D:\ only, or to D:\ and all subfolders and files (where the letter D may vary for you) -- choose D:\ only.

Now create a folder in the root of that drive that you will use to hold the floppy images. (Optionally copy in the drive image at this point).

Now go back to the drive properties and tick the box for compression, again applying the changes only to D:\

You have created an uncompressed 'island' inside a generally compressed drive. Grub4DOS does not actually care if the rest of the disk is compressed, it is happy so long as the file it is loading is uncompressed and contiguous.

Any images you copy into this folder will also remain umcompressed - so you can add further files to the folder later and they will work too.

Tested from a Win2k system, loading a floppy image as follows

CODE
title floppy image (direct mapping)
find --set-root /virtual/rbrokwin.ima
map /virtual/rbrokwin.ima (fd0)
map --hook
root (fd0)
chainloader +1
map --floppies=1

title floppy image (via memory)
find --set-root /virtual/rbrokwin.ima
map --mem /virtual/rbrokwin.ima (fd0)
map --hook
root (fd0)
chainloader +1
map --floppies=1


Before I applied the above workaround, only the memory option worked.

I removed the \virtual folder, did the above, copied the files back into the new \virtual folder, and both options now work.

I'd be interested in the results if anyone also tries this with a mapped .iso on a compressed NTFS drive.

regards,
River~~

edit: PS as expected, changes made to the 'floppy' are lost when using the memory option, but are seen on the next reboot when using the direct option
edit: added a reason why you might not want to use --mem
11 May 2009
Read Topic
Introducing river~~
hi folks,

I got interested in Grub4DOS recently when trying to install various linices onto a machine that would not boot from CD, and not properly from floppy, and ended up also using it to rescue a win2k install that had been broken by the Debian installer

I've been using Linux for some years (started with a paid-for Suse just before y2k, then once I got confident moved on to Debian, a little Gentoo, and more recently Puppy) but still have several winboxes, and a mix of Pentium II machines with w98, w2k and Debian (sarge) on a *coax* network which I got going out of interest (this may say more about me than anything else in this post) and a dual boot Vista/Debian Lenny tablet laptop.

I'm putting together a floppy disk that will be based on Grub4DOS, FreeDOS, and an extended menu.lst file - possibly to be called River's Broken Windows Floppy, or River's Broken Windows Rescue Disk.

Extras
Options
Options
Interests
No Information
Other Information
Country:: United Kingdom
Last Visitors
river~~ has no visitors to display.
Comments
Other users have left no comments for river~~.
Friends
There are no friends to display.
* Profile views updated each hour