Welcome Guest ( Log In | Register )
Digg this topic Add to my del.icio.us Submit to SlashDot 7 Pages V   1 2 3 > »   
Reply to this topicStart new topic
> WinBuilder 074, Stable release
Rating 5 V
Nuno Brito
post Dec 15 2007, 12:56 PM
Post #1


Advanced Member
***

Group: .script developer
Posts: 5,199
Thank(s): 23
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


After 6 months of beta testing I thought it would be time to release a fresh stable to replace some things in version 072 that needed to be updated.

Beware that labeling a version as "stable" doesn't necessarily mean that all possible bugs were ironed out - it just means that this version is definitively better than the last stable in regard to overall improvements.

For bug fixing - a new beta testing version 075 should be released soon to ensure that we can continue with the debugging process.

Here is the complete log of changes for this version:

QUOTE
beta 1

- Modified UI to keep tabs well separated and enlarge the size of the work window.
- Web tab now defaults to http://boot-land.net/forums instead of http://boot-land.net/forums/wb.php to give direct access to the forums
- fixed bug on web tab which kept the progress whell rotating even after the page concluded loading
- Added right-click menu to add commands on the New Script tool
- Added right-click copy/paste/cut function to codebox and New Script Tool
- Fixed the CheckList component on the interface section
- Added standalone editor mode for editing script - use winbuilder /open="mydir\myWork.script"


beta 2

- Added NativeEx server on the download list
- Corrected error messages that ocurred when editing the script's description in standalone editor mode
- Added option on standalone editor to run buttons and checkboxes
- Running a single script in unattended is much simpler, new syntax: Winbuilder.exe /run="c:\test\apps\myApp.script"
This mode will automatically try to find it's respective project file and read all default values from there if none is specified on command line
- Unattended mode can run files with any .project filename (example: winbuilder.exe %basedir%\Projects\LiveXP\LiveXP.project)
- Added stop button when running in unattended mode
- Added confirmation box when deleting attached files.
- Added button to run script inside the source code editor
- Added auto-save option inside source code editor
- Server list is directly updated from the internet instead of using built-in server addresses.
- Added button on the download tab to refresh list of available servers on the web


[beta 3]

- Added support for reading the default webpage from each web server when selected
- Changed icon for download button inside the download center
- Reverted back to default internal project processing
- Web server list is now available as a tab to keep things tidy
- Added two new commands to the IF function - question and notquestion. Example syntax: if,question,"Continue?",echo,"Hello world!"

[beta 4]

- Removed - message that appeared after saving a script in the source editor - save button automatically detects when script is modified.
- Fixed - bug that erased the contents of the script whenever using a spinedit object on the interface
- Fixed - bug that prevented loading any .script file outside the projects folder
- Fixed - Bug which appeared when selecting an error on the log window after running a script "Cannot focus disabled window"
- Fixed - bug that prevented loading .script files in editor mode using command line parameters
- Added - IniDeleteSection - support for unicode files
- Added - IniAddTextLine - support for unicode files
- Added - button to edit listed web servers inside the web server list.
- Added - missing <If,Question,"My Question?",Command> option on the right click menu of the source code editor
- Added - option to launch external editor in source code editor
- Corrected - FileCopy command with progress bar - it was only outputing the name of the filename being copied after completing the copy
- Corrected - After clicking on button inside UI - big play button is disabled
- Corrected - System,RefreshInterface is not working after pressing button on script UI
- Corrected - edit with right-click button on explorer erased everything except interface
- Corrected - Text box won't remember changes made on UI editor
- Corrected - Play button inside source code editor was not saving latest changes
- Replaced - old inimerge code was replaced with newer version (please test)
- Replaced - logo icon for source code editor tab
- Replaced - navigation icons on main window




beta 5

- Disabled - SystemRefreshInterface is not executed when called from script UI buttons
- Corrected - FileCopy was not allowing to copy a file from one location to another using a different filename
- Corrected - Replaced all "wich" typo keywords by "which"
- Corrected - IniDeleteSection was not working with UNICODE files
- Solved - bug when encoding files using beta 4 - incompatibilities between unicode vs ansi
- Added - Main script treeview is locked when changing selected status to avoid flickers.
- Added - Switch to TxtAddLine - using "unicode" as last parameter on the append line operations will write with unicode support


[beta 6]

- Fixed - bug that appeared when running the script inside the source code editor window
- Modified - Single script upload button was moved to the "Options" tab inside the script editor
- Enabled - MD5 tool to calculate MD5 checksum was readded on the "Options" tab
- Fixed - bug that "forgot" adding last folder on the "Create New script" tab


The new version can be downloaded on the winbuilder site following this link --> http://winbuilder.net/download.php?view.25


Hope you enjoy this new version - please let me know if something still needs to corrected or bug fixed.

Have a good weekend! (IMG:../forums/style_emoticons/default/smile.gif)
Go to the top of the page
 
+Quote Post
psc
post Dec 15 2007, 03:11 PM
Post #2


Guru
***

Group: .script developer
Posts: 4,316
Thank(s): 9
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


My first test with standard nativeEx_barebone: Boots into qemu, no troubles visible (IMG:../forums/style_emoticons/default/thumbup.gif)

But, Nuno, do not hurry up to be too proud (IMG:../forums/style_emoticons/default/cheers.gif) !
My current nativeEx_barebone contains a couple or walkarounds / workarounds, i coded to circumvent some known 'features'.

Let me try with the 'usual' coding

Peter

BTW: when trying to download 074, I came into the page:
Attached Image

Question: Are nativeEX_barebone and nativeEx_moa-lite not stable, or what's the reason to omitt them?

BTW2: How come into this page from the 'usual' bootland download tab?
I only came here using the EinBuilder074 link.

Peter
Go to the top of the page
 
+Quote Post
psc
post Dec 15 2007, 04:42 PM
Post #3


Guru
***

Group: .script developer
Posts: 4,316
Thank(s): 9
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


I think I found a real bug, not only an issue, which has to be fixed soon.

Try following:
  • First with WinBuilder 072:
    • Create an empty dir with WB 072 inside
    • Click 'Download' tab and choose 'Recommended'
    • Unselect everything besides 'nativeEx_barebone'
    • Do the download
    • Define XP SP2 as source and run the project
    • When asked to restart, exit WinBuilder and restart.
    • Run the project again
    • When the project booted into qEmu, test that it is working: Try a URL in OB1
    • Exit qEmu
    • Click the 'Log' tab: You see something
  • Now try exactly the same with WinBuilder 074
    • Create an empty dir with WB 074 inside
    • ...
    • Click the 'Log' tab: WinBuilder hangs
Peter
Go to the top of the page
 
+Quote Post
Nuno Brito
post Dec 15 2007, 05:58 PM
Post #4


Advanced Member
***

Group: .script developer
Posts: 5,199
Thank(s): 23
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


Hi Peter!

Thanks for testing - I did mentioned debugging is a continual process but it is very important to release an update so that other good features can be used instead of waiting too long and still having a very outdated "stable" version available.

Was this behavior you refer mentioned on the last 073 beta versions? (IMG:../forums/style_emoticons/default/huh.gif)


I'm only worried about FileCopy and some of the text handling commands (IniDeleteSection and TxtAddLine) - but these were modified on beta 3 and I've been using the latest betas to build liveXP without any issues.


Version 074 has only a few minor changes since beta 5 and none "critical" to script processing.

QUOTE
- Fixed - bug that appeared when running the script inside the source code editor window
- Modified - Single script upload button was moved to the "Options" tab inside the script editor
- Enabled - MD5 tool to calculate MD5 checksum was readded on the "Options" tab
- Fixed - bug that "forgot" adding last folder on the "Create New script" tab


-------------------

QUOTE
Question: Are nativeEX_barebone and nativeEx_moa-lite not stable, or what's the reason to omitt them?

Please make available nativeEx as a single download package and it will be included on the project section.

It is possible to place a direct link to a file on your web space and this way you'd be able to update this single package file whenever needed.

I also noticed that the VistaPE project wasn't mentioned either - these are things that should be corrected soon - sorry for this annoyance.


QUOTE
BTW2: How come into this page from the 'usual' bootland download tab?
I only came here using the WinBuilder074 link.


You hadn't yet visited the new winbuilder site? (IMG:../forums/style_emoticons/default/smile.gif)

Go to the top of the page
 
+Quote Post
psc
post Dec 15 2007, 06:23 PM
Post #5


Guru
***

Group: .script developer
Posts: 4,316
Thank(s): 9
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


QUOTE (Nuno Brito @ Dec 15 2007, 06:58 PM) *
Was this behavior you refer mentioned on the last 073 beta versions? (IMG:../forums/style_emoticons/default/huh.gif)

On beta 1 I did not find it (but maybe there have been different conditions)
Sorry, I did not test later betas.
I've had some troubles with beta 1(I hope I posted) and because of beeing rather busy with other tasks, I did not test later betas.
QUOTE (Nuno Brito @ Dec 15 2007, 06:58 PM) *
I'm only worried about FileCopy and some of the text handling commands (IniDeleteSection and TxtAddLine) - but these were modified on beta 3 and I've been using the latest betas to build liveXP without any issues.

Maybe these are responsible for the behaviour?
QUOTE (Nuno Brito @ Dec 15 2007, 06:58 PM) *
Please make available nativeEx as a single download package and it will be included on the project section.
It is possible to place a direct link to a file on your web space and this way you'd be able to update this single package file whenever needed.

Please give a sample what to do.
QUOTE (Nuno Brito @ Dec 15 2007, 06:58 PM) *
You hadn't yet visited the new winbuilder site? smile.gif

Imagine, I'm a newbie and Google leads me to 'www.boot-land.net'
How coming to www.winbuilder.net?

Peter
Go to the top of the page
 
+Quote Post
TheHive
post Dec 15 2007, 08:46 PM
Post #6


Advanced Member
***

Group: .script developer
Posts: 2,201
Thank(s): 3
Joined: 14-July 06
Member No.: 5



We should have a visible link from the forum to
http://winbuilder.net

"Psc" if you have youre old Stable project for Winbuilder 52. It would good to release is as a package with Winbuilder52.

And the latest stable release for Winbuilder72a and so on. That way we can always have an older ones just to bring it up in the future and see all the changes.

I was looking at the changes from where we started from Batcher and man. What a difference. We forget all the stuff that has been put into these projects.

Things are looking more polished from my perspective.

As for Vista Project.
This is a good base.
http://www.vistape.net/files/vistape010-base.rar

The full project might want to be created of the one from the server before it is changed to v11 soon.



Go to the top of the page
 
+Quote Post
Nuno Brito
post Dec 15 2007, 09:07 PM
Post #7


Advanced Member
***

Group: .script developer
Posts: 5,199
Thank(s): 23
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


Maybe you could compare version 073 beta 3 to confirm if this is the case - hopefully just a quick update should solve this specific matter.

At the time UNICODE was mentioned here: http://www.boot-land.net/forums/index.php?showtopic=3573

FileCopy was recoded - all other commands remain mostly intact.

-----------


QUOTE
Please give a sample what to do.


- Create a fresh folder with winbuilder.exe and all your project files including common files like tools and such
- Clean any personal informations like %sourcedir% paths for example and delete any temporary files
- Make a single zip file with all the contents of this folder

----

If a user comes into boot land it shouldn't be too hard to find enough information to know where to get the latest versions - the fixed topic for winbuilder is also pointing to the new site --> http://www.boot-land.net/forums/WinBuilder-t5.html

---

TheHive - you're right, I've also been visiting "older" versions and have things moved on a fast pace or what? (IMG:../forums/style_emoticons/default/rolleyes.gif)

Unfortunately most of my archives weren't kept as I often overwrite older versions with more recent ones - if you (or anyone else) have any good packages to include on the site then it would be good to have them as reference and finally start creating some sort of library where everyone can download these resources as necessary.

Will add the VistaPE 10 rar file in the meanwhile.

btw: WinBuilder 052 package can already be found here --> http://winbuilder.net/download.php?view.2

(IMG:../forums/style_emoticons/default/smile.gif)
Go to the top of the page
 
+Quote Post
psc
post Dec 16 2007, 09:26 AM
Post #8


Guru
***

Group: .script developer
Posts: 4,316
Thank(s): 9
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


QUOTE (Nuno Brito @ Dec 15 2007, 10:07 PM) *
Maybe you could compare version 073 beta 3 to confirm if this is the case - hopefully just a quick update should solve this specific matter.

At the time UNICODE was mentioned here: http://www.boot-land.net/forums/index.php?showtopic=3573

FileCopy was recoded - all other commands remain mostly intact.


Test with 073 beta 3:
Hangs, too.

Peter
Go to the top of the page
 
+Quote Post
Nuno Brito
post Dec 16 2007, 11:07 AM
Post #9


Advanced Member
***

Group: .script developer
Posts: 5,199
Thank(s): 23
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


Testing with 074

- Placed 074 on a clean folder
- After initial project download and restart everything looks ok.
- Running initial script downloads several tools required by the project
- WBverify script outputs the following message

QUOTE
Generated by psc program 'WBVerify' version 2.0.0
Date: 2007-Dez-16 09:43:32

[Counts]
Missing=0
Obsolete=5
Errors=0
Warnings=0

Obsolete: \Tools\ReOpen.Link (Renamed and moved)
Obsolete: \RestoreBase\RestoreBase.Link (Renamed and moved)
Obsolete: \Basic\Tweaks\pscNamePC.Link (Renamed and moved)
Obsolete: \Basic\Tweaks\autoLocalization.Link (Renamed and moved)
Obsolete: \Basic\Tweaks\autoKeyboard.Link (Renamed and moved)


After this it took a while to load on qemu but no errors were reported on the log.

Look here --> Attached File  log.7z ( 89.56K ) Number of downloads: 12


--------------

I was thinking that there was any sort of error going on the script engine but now I understand that this is not the case.

The log window needs to be optimized for speed - somehow it became sluggier (on my 1Gb dual core it takes a minute to update all entries on a full xp build)

It has nothing to do with Unicode or the FileCopy - this is a relief.

-------

I'll try to debug and see why it became so slow on extensive log lists.

(IMG:../forums/style_emoticons/default/smile.gif)

Go to the top of the page
 
+Quote Post
psc
post Dec 16 2007, 11:33 AM
Post #10


Guru
***

Group: .script developer
Posts: 4,316
Thank(s): 9
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


QUOTE (Nuno Brito @ Dec 16 2007, 12:07 PM) *
The log window needs to be optimized for speed - somehow it became sluggier (on my 1Gb dual core it takes a minute to update all entries on a full xp build)

I can confirm that.
Really no hang, only a long time for the log to come up.

I have been too impatient.

Peter
Go to the top of the page
 
+Quote Post

7 Pages V   1 2 3 > » 
Fast ReplyReply to this topicStart new topic

Members Who Viewed Topic Today ()

 

RSS Lo-Fi Version Time is now: 25th April 2008 - 01:17 AM

MKPortal ©2003-2008 mkportal.it