Digg this topic Add to my del.icio.us Submit to SlashDot  
Reply to this topicStart new topic
> LAN port starts to toggle when TFTP transfer starts
earwik
post Sep 12 2007, 01:44 PM
Post #1


Newbie
*

Group: Members
Posts: 3
Joined: 12-September 07
Member No.: 10,605


Belgium


Hi,

I have a setup in which a device is a TFTP client and TFTPD32 on my Windows XP Pro machine is the DHCP and TFTP server for this client. At a certain stage, the client requests a file from the server. On that moment my LAN port starts to toggle between link up, link down during the whole period the client tries to download the file. When the client gives up, the LAN port stays up.

I tried changing settings in TFTPD32 itself, on the LAN card, Windows firewall, alas... no effect.
I tried using a different LAN port (a PCMCIA card), but also that did not work.
I tried using a different PC (exactly the same as mine, which is a HP Compaq nc6320) and this worked!
(IMG:../forums/style_emoticons/default/frusty.gif)
What could be wrong with my PC that the TFTP download does not work?

Cheers,

Earwik
Go to the top of the page
 
+Quote Post
jaclaz
post Sep 12 2007, 02:18 PM
Post #2


Finder
***

Group: Advanced user
Posts: 1,119
Joined: 14-July 06
Member No.: 2


Italy


VERY hard to say. (IMG:../forums/style_emoticons/default/sad.gif)

I remember there were some Virii, some time ago, that used TFTP for doing whatever Virii do and made the LAN port behave as you describe.

If you are positive that you are Virus free and that the tftp.exe file has not been tampered with, the problem might lie in some Registry entry, but cannot even give you a hint where on Registry to search for.

Maybe, just maybe, a Virus removal tool like this:
http://www.sophos.com/support/disinfection/blastera.html
might restore the correct Registry entries.

Did you check the Event Logs for anything unusual?

jaclaz
Go to the top of the page
 
+Quote Post
earwik
post Sep 12 2007, 03:06 PM
Post #3


Newbie
*

Group: Members
Posts: 3
Joined: 12-September 07
Member No.: 10,605


Belgium


By the way, here are the Ethereal captures for a successful and an unsuccessful download.
Attached File(s)
Attached File  CP_bad.cap.txt ( 2.41k ) Number of downloads: 9
Attached File  CP_good.cap.txt ( 1.71mb ) Number of downloads: 10
 
Go to the top of the page
 
+Quote Post
earwik
post Sep 13 2007, 09:35 AM
Post #4


Newbie
*

Group: Members
Posts: 3
Joined: 12-September 07
Member No.: 10,605


Belgium


Thanks for the tips jaclaz.

My system is clean (I ran various tools). The only event log I see is:
Event Type: Information
Event Source: Tcpip
Event Category: None
Event ID: 4201
Date: 13/09/2007
Time: 11:32:44
User: N/A
Computer:
Description:
The system detected that network adapter D-Link DFE-650TXD Fast Ethernet PC Card was connected to the network, and has initiated normal operation over the network adapter.

So also that is OK. I'm really running out of ideas here!

Cheers,

Earwik.
Go to the top of the page
 
+Quote Post
« Next Oldest · Tftpd32 · Next Newest »
 

Fast ReplyReply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts TFTPD32 with Cisco 6509
Access denied Error 32 Problem
3 Peter H 627 9th October 2007 - 10:00 AM
Last post by: Jonathan Hall
No New Posts Portable apps
Minimal sized and portable free apps
6 Nuno Brito 787 26th September 2007 - 11:30 PM
Last post by: Nuno Brito
No New Posts Total Commander script
1 drob 333 8th September 2007 - 03:35 PM
Last post by: Ove
No New Posts TFTPD32 stops responding
3 kryten 1,077 30th August 2007 - 07:27 AM
Last post by: kryten
No New Posts TFTP32 client mode and source/destination IP address
1 tnguyen41 630 9th August 2007 - 07:33 PM
Last post by: jaclaz


 


Track this topic · Email this topic · Print this topic · Subscribe to this forum

- Lo-Fi Version Time is now: 13th October 2007 - 04:19 AM

MKPortal ©2003-2006 mkportal.it