IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Rating
 
Options
Options
Personal Statement
ilko doesn't have a personal statement currently.
Personal Info
ilko
Advanced Member
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Other Information
Country:: Bulgaria
Statistics
Joined: 27-May 07
Profile Views: 0*
Last Seen: Today, 12:06 AM
Local Time: Sep 15 2008, 04:24 AM
103 posts (0.22 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Send Message
Contact Private
* Profile views updated each hour

ilko

Members

***


Topics
Posts
Files E2T
Comments
Friends
My Content
26 Jun 2008
Read Topic
help with grubinst.exe
I am writing an autoit scrpit. It installs grub4dos bootsector on an USB disk partition.
CODE
RunWait(@ScriptDir & "\files\grubinst.exe -v --pause " & $trggrub, "", @SW_SHOW)

which in produces:
grubinst.exe -v --pause (hd3,0)

$trggrub is (hd3,0), I triple checked that.

The issue is the even though grubinst.exe reports :
QUOTE
Start sector: 0x3F
Image type: FAT12/FAT16
Install mode
The MBR/BS has been successfully installed
Press <ENTER> to continue ...


This is on the USB stick:
(IMG:http://img295.imageshack.us/img295/4312/magicalsnap200806261634fx6.th.jpg)

What is strange for me, is that if I make a new autoit file, containing only 2 lines:
CODE
$trggrub = "(hd3,0)"
RunWait(@ScriptDir & "\files\grubinst.exe -v --pause " & $trggrub, "", @SW_SHOW)

it works, grub4dos bootsector is written.

What could be wrong? Is the question rather related to AutoIt? If yes, why grubinst.exe reports success, but no BS is written? Open handles to that drive? Delayed writes because it's USB? What else it could be?

Using grubinst-1.1-bin-w32-2008-01-01 from http://download.gna.org/grubutil/

I read:
QUOTE
--duce disable the feature of unconditional entrance to the command-line.
and did understand it fully. Anyway I tried it- no change, bootsector still not written.
6 Jun 2008
Read Topic
Grub4dos MBR, makeactive and geometry, a few questions
Hi,

A few questions about grub4dos-

1. What are downsides of using Grub4dos MBR, which comes with the package? Remembered a few notes from Jaclaz, who mentioned commercial tools, writing on the same range of sectors outside MBR itself. Are there any reports about problems with that?
Are the same sectors used when it's installed into the bootsector or code is reduced size then? Is that a safer option?

2. Use grubinst on USB stick. My motherboard Gigabyte P965-DS3P has a few options for USB boot- pressing F12 gives you boot options, where usually USB sticks with NT MBR appear among the internal hard disks. There are separate entries for USB-HDD, USB-FDD, USB-ZIP and USB-CDROM.
With NT MBR everything is fine, it is seen as hard disk, grub4dos gives it hd0.
After grubinst USB stick is no longer among the internal hard disks, using USB-HDD would boot it. However, stick is now emulated as FD and seen from grub4dos as FD0. Booting MS-DOS, NTLDR, SETUPLDR.BIN is not possible. First keeps asking for command.com, second complains about fatal error1 missing boot.ini, third just restarts. No INT13 for the USB stick? Silly BIOS, fine.
But why using grub4dos MBR changes the behavior? Is BIOS looking for a specific flag in the MBR and which one it should be? Isn't it good idea to take it into consideration ?
The same stick gets hd0 when booted on another machine- Dell Inspiron 6000.
If I recall correctly similar issues were when I was playing with other boot managers and MBRs installed by them, was it makebootfat, PLOP or syslinux I forgot.

3. About MAKEACTIVE- what is expected syntax? Is it supposed to return the result, something like "(hd0,4) successfully set active", or anything, just to know that it succeeded?
makeactive --status does not return anything. Nor does makeactive --status (hd0) or makeactive --status (hd0,0).

4. Might be a good idea geometry command to display the active partition too, unless there is another command for that.

5. Why syslinux LDLINUX.SYS cannot be chainloaded directly, neither with chainload /ldlinux.sys nor kernel /ldlinux.sys, or it can be, what's the trick? An image with syslinux bootsector works, but direct chainload would be very useful.

Used the version from 2008-05-02.

ilko
13 Apr 2008
Read Topic
Start Grub4DOS GRLDR from NT bootsector, why not working?
I am trying to launch Grub4DOS either by changing in NT bootsector NTLDR to GRLDR, or by renaming GRLDR to NTLDR. Both ways fail.
USB stick formated by HP USB format utility and PEtoUSB. Tried all format options- FAT16, 16X, 32, NTFS.
Grub4Dos versions 14-03-2008 , 0.4.3 from 10.2007 and the stable 0.4.2.
Using various format options result in either blinking cursor, "please remove disk or other media", "FATAL INT18:BOOT FAILURE" in QEMU, or starting from the second disk.
Tests on Dell Inspiron 6000 and QEMU.
In all formatting options using ntldr or setupldr.bin, bootmgr renamed to ntldr start fine.

Am I missing something, or simply GRLDR cannot be started from NT bootsector ? As far as I remember there were posts on 911cd.net describing success renaming GRLDR to NTLDR, I never had such on my machines.

Reading README_GRUB4DOS.txt description of GRUB-bootable bootsector doesn't help me much to get the details what is wrong.
I'd like to avoid using bootlace.exe or grldr.mbr to start directly grub4dos, as well as using NTLDR/boot.ini to chainload GRLDR.

What would be the easiest way to format USB stick and make it GRUB4Dos bootable considering the written above?

ilko
31 Mar 2008
Read Topic
Start Grub4DOS from kexec-loader, possible?
Just came across this project:
http://solemnwarning.no-ip.org/kexec-loader/

Unfortunately it lacks documentation.

The idea- start kexec-loader, it has USB, hopefully USB2 drivers, load Grub4DOS, chainload ntldr/setupldr.bin or ISO boot.
Kexec-loader might help booting from non USB boot friendly motherboards and probably gain USB2 speed on MBs supporting only 1.x speed.

Would someone with greater experience have a look. Would it serve that idea? Would ntldr/setupldr.bin be able to boot successfully when loaded that way? Any thoughts would be appreciated.

ilko


9 Mar 2008
Read Topic
Long delay at "GRLDR is booting" when starting latests GRUB4Dos
Hi,

Using latest Grub4dos on my system causes long delay when booting from USB stick. It gets stuck at "GRLDR is booting" for about 2:40 minutes. After that everything is normal.

Here are the versions where boot is slow:

0.4.3 2008-01-03
0.4.3 2007-12-25
0.4.3 2007-12-14
Haven't tried yet all previous.

These have no problems:
0.4.2 2006-12-31
0.4.3 2007-10-15

Motherboard- Gigabyte 965P-DS3P
C2D 4300@2.9
2GB RAM
F5 BIOS

1GB Transcend JetFlash USB stick formated FAT16 from PEtoUSB, LBA makes no difference. Tried HP USB format tool too- no difference.
Can't boot from USB if FAT32 is used.
GRLDR is chainloaded from NTLDR/boot.ini- C:\GRLDR

I need to use ISO emulation options found in latest versions.
Would that information help you fix it? Or it's buggy BIOS/MB?

Last but not least- many many thanks for this great software (IMG:../forums/style_emoticons/default/thumbup.gif)


Regards,
ilko
Last Visitors


24 Aug 2008 - 7:51
Drake Sorcere...


26 Jul 2008 - 21:43


24 Jun 2008 - 20:50
ulicky


22 Jun 2008 - 19:01
petrix


21 Apr 2008 - 15:43

Comments
Other users have left no comments for ilko.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 15th September 2008 - 03:24 AM
IPS Driver Error

IPS Driver Error

There appears to be an error with the database.
You can try to refresh the page by clicking here