IPB

There is 6 page(s)  1 Page : 2 Page : 3 Next page Go to last page  
 
> New VPELDR.exe - testers wanted
 
 ctmag
post Jan 26 2009, 04:04 PM
Post #1


Silver Member
****

Group: .script developer
Posts: 678
Joined: 19-May 08
Member No.: 15,320


Germany


Hello,

I made some changes to vpeldr.exe

I hope that this will help with the current driver troubles. Anyone who thinks he/she knows what vpeldr.exe is and who is able to replace the original version with the one attached here (replace attached vpeldr.exe in basic configuration and tools script) is welcome testing it.

What i did:

- many small fixes and changes
- it generates a (basic) logfile in system32\vpeldr.log
- completely removed all things related to hardwaredetection and driver installation
- no longer uses uictl.exe to set screen resolution
- no longer uses devmgr.exe
- no longer depending on devcon.exe
- no longer has files like uictl.exe compiled in the vpeldr.exe
update:
- vpeldr.exe no longer scans periodically for new config files (this caused trouble when running from usb HD and i think noone ever used it...)
- fixed startmenu

The reasons for removing the hardware detection:
- for many users loading extra drivers is not needed
- the system starts faster
- unloading already working drivers should no longer happend
- a completely new tool will be developed to just handle driver issues, but i want it out of vpeldr.exe


Please report here how it works for you, especially if you loose any functionallity due to not loaded drivers...thanks!

This post has been edited by ctmag: Jan 27 2009, 06:28 AM
Reason for edit: attached new version with very small change

Attached File(s)
Attached File  vpeldr.zip ( 457.91K ) Number of downloads: 68
 
Go to the top of the page
 
 
 PaPeuser
post Jan 26 2009, 07:47 PM
Post #2


Frequent Member
***

Group: Advanced user
Posts: 106
Joined: 31-August 08
From: Earth USA Pa.
Member No.: 17,811


United States


Ater reading all the News today I would test this first

I think this is where to start with any updating of Vista

Could someone replace this in Winbuilder and send, or point me to a place i can Download it ?

Go to the top of the page
 
 
 amalux
post Jan 26 2009, 08:16 PM
Post #3


bug-catcher
*****

Group: Tutorial Writer
Posts: 1,138
Joined: 1-February 07
From: California
Member No.: 2,966


United States


QUOTE (PaPeuser @ Jan 26 2009, 11:47 AM) *
Ater reading all the News today I would test this first

I think this is where to start with any updating of Vista

Could someone replace this in Winbuilder and send, or point me to a place i can Download it ?

Extract the vpeldr.exe somewhere (from ctmag's link)

Open wb and go to Basic Config script
Attached Image


Delete and replace existing vpeldr.exe with new from ctmag
Attached Image
Go to the top of the page
 
 
 ctmag
post Jan 26 2009, 08:19 PM
Post #4


Silver Member
****

Group: .script developer
Posts: 678
Joined: 19-May 08
Member No.: 15,320


Germany


I was to busy to make an how-to....thanks for doing it for me:-)
Go to the top of the page
 
 
 PaPeuser
post Jan 26 2009, 08:32 PM
Post #5


Frequent Member
***

Group: Advanced user
Posts: 106
Joined: 31-August 08
From: Earth USA Pa.
Member No.: 17,811


United States


Thanks

I did that
BUT
I use or have WinRAR installed and for some reason it would not delete or replace,

i will figure it out, (IMG:../forums/style_emoticons/default/smile.gif)
Thanks again,,,
Go to the top of the page
 
 
 ctmag
post Jan 26 2009, 08:59 PM
Post #6


Silver Member
****

Group: .script developer
Posts: 678
Joined: 19-May 08
Member No.: 15,320


Germany


delete and replace must be done with the WB functions...see the screenshots...the buttons are marked with colored circles...
Go to the top of the page
 
 
 e2p2
post Jan 26 2009, 09:15 PM
Post #7


Member
**

Group: Members
Posts: 30
Joined: 18-July 08
Member No.: 16,698


United States


I have added this to my build. And it works well. The only thing I don't link is the start menu is collapsed into one tree. Can you set it so that the looks like a standard start menu with most items starting under Programs.
Go to the top of the page
 
 
 homes32
post Jan 26 2009, 09:38 PM
Post #8


Newbie
*

Group: Members
Posts: 17
Joined: 7-July 08
From: Minnesota
Member No.: 16,433


United States


QUOTE (e2p2 @ Jan 26 2009, 03:15 PM) *
I have added this to my build. And it works well. The only thing I don't link is the start menu is collapsed into one tree. Can you set it so that the looks like a standard start menu with most items starting under Programs.

same here, everything seems to be working nicely except for the start menu being screwed up.
Go to the top of the page
 
 
 PaPeuser
post Jan 26 2009, 11:14 PM
Post #9


Frequent Member
***

Group: Advanced user
Posts: 106
Joined: 31-August 08
From: Earth USA Pa.
Member No.: 17,811


United States


Ok just some first looks

BSexplorer - Shell

Start menu is different
Running Hardware Detect X from task bar was no help

Failed to start network support from taskbar
VPE loader & tools no longer runs Detect Hardware (slow mode)

Device Manager does not detect my network card
USB hard drives are all detected and listed
More is listed under - Other devices
Less is listed under - System devices

Explorer - Shell
Start Menu Most listed do not expand or open
Example start System to get to Device Manager

So I cant refresh device manager except in BSexplorer

Peloader tools closes under Explore Shell
I cant reopen it to get back to BSexplorer shell

More later
Go to the top of the page
 
 
 amalux
post Jan 27 2009, 12:52 AM
Post #10


bug-catcher
*****

Group: Tutorial Writer
Posts: 1,138
Joined: 1-February 07
From: California
Member No.: 2,966


United States


Well first, the new loader takes about a minute vs 8 for the old one (IMG:../forums/style_emoticons/default/thumbup.gif)

Unfortunately, there's a price paid, mainly in hw detection; lost my network (IMG:../forums/style_emoticons/default/sad.gif)
Attached Image


Oh, that Start Menu is really annoying as well, any fix?
Attached Image
vs
Attached Image
Go to the top of the page
 
 
 
 

There is 6 page(s)  1 Page : 2 Page : 3 Next page Go to last page 
 
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

Collapse

>

  Topic Replies Topic Starter Views Last Action
No new Posts Pinned: Topic has attachments Newcomer's Tutorial - LiveXP with Optional BootSDI!
Bug reports and troubleshooting thread
221 doveman 10,107 Yesterday, 04:38 PM
Last post by: amalux
No New Posts New guy
Checking things out
4 Laird 68 28th January 2009 - 08:57 AM
Last post by: jaclaz
No New Posts Newish CD/ISO/whatever format and Virtual disk
Mounting files as filesystem objects
3 jaclaz 380 27th January 2009 - 10:24 PM
Last post by: Galapo
No New Posts Newsletter, 25th of January!
0 Nuno Brito 53 25th January 2009 - 06:40 PM
Last post by: Nuno Brito
No new Posts Topic has attachments New Beta Script for VistaPE
Feature of Windows Vista
42 ludovici 1,959 25th January 2009 - 01:51 AM
Last post by: PaPeuser


 
menu_build_menu( "topicreferrals", new Array( img_item + "   12 clicks", img_item + " http://boot-land.net/foru...s/wb_server.php   8 clicks" ) );

RSS "Boot-Land.net", "WinBuilder" Lo-Fi Version Time is now: 31st January 2009 - 08:32 PM