Hello dear guest!

Why not join our boot disk community? So do it. Life's short!

  - You get free access to our newsletter with all the interesting buzz about boot disks
  - We share publicity revenue with everyone who wishes to participate at the forums
  - Publicity is never, never, never displayed to members (along with many other cool things)
http://boot-land.net/register

6 Pages V  « < 2 3 4 5 6 >  
Reply to this topic
 inf - script together support suggestion for wb, Chief Nuno your opinion needed
post Dec 6 2008, 08:54 PM
Post #31
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


Peter,

'yyyyfolderwa2' is not a command
it is the folder where Winamp2 installed on BartPE
in sherpya/bartpe location of winamp.exe is:
X:\Programs\yyyyfolderwa2\Winamp.exe
in livexp (eng) location of winamp.exe is
X:\Program Files\yyyyfolderwa2\Winamp.exe


QUOTE (psc @ Dec 6 2008, 10:46 PM) *
I (in programming cheers.gif ) never preferred the easier way rather than the correct one.


"[PEBuilder] winbuilder=0" is also correct, solution method is different.

as i wrote before, you should leave user to decide if he wants to use "[PEBuilder] winbuilder=0" or not.


--------------------
+Quote Post
post Dec 11 2008, 12:50 AM
Post #32
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


Hi Peter,

putting 'Convert' to all found .inf files that dont have [PEBuilder] is a very bad idea,
it makes startup of winbuilder veryslow when drivers are used in %scriptfolder% which also makes unwanted 'Convert' .inf on gui. (also others may use .inf file(s) that are not relevant to pebuilder for different purposes too)

old method was (i guess) searching for [PEBuilder] in .inf file, which was working nicely.
At current topic I only reported
[PEBuilder]<space>
issue which in result i didnt expect that kind of solution.


--------------------
1 user(s) said "Thank you!" to Lancelot for this fantastic post:
psc
+Quote Post
post Dec 11 2008, 08:16 AM
Post #33
psc
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


Germany


Thanks, Lancelot!

That is a bug I introduced unintended when I fullfilled yout question to inclose BartPE scripts in apostrohes.
CODE
          if AnsiEndsText('.inf', WorkFile) then begin
              FileLevel := '5';
              ScriptTitle := '''' + trimDelim(IniReadString(WorkFile, 'PEBuilder', 'Name', ''), '"') + '''';
              // We want to have only BartPE plugins.
              // in the inf is part of a driver, skip it
              if ScriptTitle = '' then
                goto Next;


Here the script title is not empty, but two apos. So WB continues frusty.gif

Peter


--------------------
Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

1 user(s) said "Thank you!" to psc for this fantastic post:
Lancelot
+Quote Post
post Dec 11 2008, 11:57 AM
Post #34
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


Hi Peter,

here is sth:

What i want is:
when wb finds [PeBuilder] than wb search for [Main] in same .inf file.

[PeBuilder]-->NO ===>Do nothing (now working that way)
[PeBuilder]-->YES + [Main]-->NO ===> Put double quote to name " (at current it puts single quote)
[PeBuilder]-->YES + [Main]-->YES ===> Put single quote to name ' (at current it puts single quote)




i hope you understand ?!

Edit: [Process] changed to [Main]


--------------------
+Quote Post
post Dec 11 2008, 12:01 PM
Post #35
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


ahh sorry
in previous post i use
[Main] in picture
[process] on text post

now i editing [Main] in the text.


--------------------
+Quote Post
post Dec 11 2008, 02:06 PM
Post #36
psc
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


Germany


That's a idea which can be realized! thumbup.gif

Peter


--------------------
Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Dec 11 2008, 03:03 PM
Post #37
psc
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


Germany


Lancelot!

Try next inofficial preview from same URL

Peter


--------------------
Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Dec 11 2008, 05:57 PM
Post #38
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


psc

Yes, now it is nicer cheers.gif thumbup.gif

Only 2 things left to close this topic smile.gif
1) creating shortcut with right name right place

reminding with old posts as you like:

QUOTE (Lancelot @ Dec 6 2008, 10:33 PM) *
psc

0x2, "Sherpya\XPEinit\Desktop", "yyyyyy", "%SystemDrive%\Programs\yyyyfolderwa2\Winamp.exe"
0x2, "Sherpya\XPEinit\Programs", "yyyyyy", "%SystemDrive%\Programs\yyyyfolderwa2\Winamp.exe"
<MITEM TYPE="ITEM" DISABLED="@Not(@FileExists(@GetProgramDrive()\Programs\yyyyfolderwa2\winamp.exe))" CMD="RUN" FUNC="@GetProgramDrive()\Programs\yyyyfolderwa2\winamp.exe">xxxxxxx</MITEM>

Here is result with Sherpya:


Here is result with LiveXP:


QUOTE (Lancelot @ Dec 6 2008, 10:54 PM) *
'yyyyfolderwa2' is not a command
it is the folder where Winamp2 installed on BartPE
in sherpya/bartpe location of winamp.exe is:
X:\Programs\yyyyfolderwa2\Winamp.exe
in livexp (eng) location of winamp.exe is
X:\Program Files\yyyyfolderwa2\Winamp.exe


--------------------
+Quote Post
post Dec 11 2008, 06:07 PM
Post #39
psc
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


Germany


It still is in my mind. But for me currently with low priority. I hope you understand.

If the issue in early 2009 is still open, you may use your chair.gif again.

See you next week on the new server.

Peter cheers.gif


--------------------
Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Dec 18 2008, 10:12 PM
Post #40
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


tested with wb075b5I:

besides a43 i put winamp.inf to nativeex too to show the error (same error with different reaction).

here is the movie
http://lancelot.winbuilder.net/5F/infsupporteditinferror.rar


Movie Info:
00:00 - 00:16
winbuilder.exe first run, .inf files with main section should be with one quote ( ' )and .inf files without main section should be with double quote ( " )
but as you see Winamp2_Kare have single quote, and a43 have double quotes !!!
00:16 - 00:18
Also winbuilder dont read version info of winamp2_kare.inf from [Main] section
00:25 - 00:40
When i edit winamp2_kare.inf, single quotes gone !!!! , but version info came (v7) smile.gif
00:40 - 01:02
When i edit a43.inf, double quotes gone, instead single quote came !!!!

00:25 - 01:02 ----> also happens when i make a build


hope it is understandable and clear and considered as 'reported carelfully'. smile.gif


ps: having "[PEBuilder] winbuilder=0" option would make life easier smile.gif.


--------------------
+Quote Post

6 Pages V  « < 2 3 4 5 6 >
Reply to this topic
1 User(s) are reading this topic ()





Collapse

  Topic Replies Topic Starter Views Last Action
No New Posts Script Drive Letter Change in WinPE 3.0
7 crazykroger 480 19th November 2009 - 05:12 AM
Last post by: allanf
No new Topic has attachmentsScript integrity
Added feature in WinBuilder.exe
39 psc 2,010 15th November 2009 - 06:50 PM
Last post by: psc
No New Posts wbzip.exe
is difficult to find ?
7 wendy 409 10th November 2009 - 09:22 AM
Last post by: wendy
No New Posts Format USB stick without HP Format tool
are there scriptable alternatives that run under xp,vista and 7?
5 ctmag 588 6th November 2009 - 04:49 PM
Last post by: jaclaz
No New Posts Forum fatal error message clicking one topic
1 ktp 191 28th October 2009 - 07:38 PM
Last post by: jaclaz


Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum