Hello dear guest!

Why not join our boot disk community? So do it. Life's short!

  - You get free access to our newsletter with all the interesting buzz about boot disks
  - We share publicity revenue with everyone who wishes to participate at the forums
  - Publicity is never, never, never displayed to members (along with many other cool things)
http://boot-land.net/register

4 Pages V   1 2 3 > »   
Reply to this topic
 Stray registry entry
post Sep 28 2008, 11:51 PM
Post #1
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


I'm getting the following registry entry created on my local host machine when building LiveXP: 'HKCU\WB-Temp\System\CurrentControlSet\Control\Windows\ShellErrorMode'. Obviously, there is a typo somewhere where 'HKCU' should rather be 'HKLM'. However, I am at a loss in finding the culprit. A text search in all scripts results in nothing.

Does anyone else get such an entry appearing in their registry? Any ideas on where the issue is coming from?

Thanks,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.


+Quote Post
post Sep 29 2008, 12:20 AM
Post #2
amalux
bug-catcher   *****
Group: Tutorial Writer

  Joined: 1-February 07 From: California

Posts: 1,403
Thank(s): 169


United States


QUOTE (Galapo @ Sep 28 2008, 04:51 PM) *
I'm getting the following registry entry created on my local host machine when building LiveXP: 'HKCU\WB-Temp\System\CurrentControlSet\Control\Windows\ShellErrorMode'. Obviously, there is a typo somewhere where 'HKCU' should rather be 'HKLM'. However, I am at a loss in finding the culprit. A text search in all scripts results in nothing.

Does anyone else get such an entry appearing in their registry? Any ideas on where the issue is coming from?

Thanks,
Galapo.

Havn't seen this, what build are you using that I can test?


--------------------
"The true measure of a man is how he treats someone who can do him absolutely no good." — Samuel Johnson

"Whether you think that you can, or that you can't, you are usually right." — Henry Ford

LiveXP w/BootSDI Tutorial - My Scripts - My Builds - Portable-ppAX
+Quote Post
post Sep 29 2008, 12:28 AM
Post #3
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


My own personal one which is somewhere between the 'recommended' and 'complete' options of LiveXP.

I'll test the offical versions now and see if also occurs and let you know.

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Sep 29 2008, 01:51 AM
Post #4
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


I found the cause: if the option 'Use DLL init at build time rather than at boot time' is selected on the explorer script, then the particular entry is generated. I don't know why and will PM Peter.

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Sep 29 2008, 02:02 AM
Post #5
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


just messaging that i havent found any thing, i havent made full tests for a while, this cause me do so, and i may find sth and will report soon smile.gif
'Use DLL init at build time rather than at boot time' is never selected in my build so that is why i didnt get that smile.gif

only reminding these links, may or maynot be relevant:

http://www.boot-land.net/forums/index.php?...amp;#entry45185
http://www.boot-land.net/forums/index.php?...ost&p=44894


--------------------
+Quote Post
post Sep 29 2008, 03:58 AM
Post #6
amalux
bug-catcher   *****
Group: Tutorial Writer

  Joined: 1-February 07 From: California

Posts: 1,403
Thank(s): 169


United States


'Use DLL init at build time rather than at boot time', if checked, has always caused serious corruption in my registry (renders IE unusable). I think this is why it was set to unchecked by default wink.gif


--------------------
"The true measure of a man is how he treats someone who can do him absolutely no good." — Samuel Johnson

"Whether you think that you can, or that you can't, you are usually right." — Henry Ford

LiveXP w/BootSDI Tutorial - My Scripts - My Builds - Portable-ppAX
+Quote Post
post Sep 29 2008, 05:22 AM
Post #7
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


I always have the option checked as it causes no issues on my machine. This is the only minor glitch I've encountered. Anyway, I'm glad we've found the cause and that since the option is unchecked by default (ie, unless I have a lapse of concentration and upload with it checked after testing myself with the option checked), there is no real problem for end users.

(As an aside, I don't have to rely on this particular script option to render IE unusable, I like to do that personally myself!)

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Sep 29 2008, 06:40 AM
Post #8
Nuno Brito
Platinum Member   ******
Group: .script developer

  Joined: 13-July 06 From: Coimbra

Posts: 7,685
Thank(s): 311


Portugal


'Use DLL init at build time rather than at boot time' is a feature that allows to register a DLL/OCX on build time and save the time from having to register the same DLL everytime the boot disk starts up.

It's a very cool feature if you compare it to XPE where you'd sit and wait until everything is done.

http://www.boot-land.net/forums/?showtopic=2745
http://www.boot-land.net/forums/index.php?showtopic=2705

-------

Only one thing comes to mind - I wonder if the order where they are registered means anything?

On Amalux case - IE is first installed (on build time) and only then comes explorer DLL's to allow make things work when it is booting up.

I wonder if it would be possible to create a waiting list of DLL's to be installed while the build is going on and only install them when the build is on the last level scripts?

btw: Can you post the script that you're using? I remember posting one for liveXP some time ago but it was very incomplete, ispy has posted a tutorial regarding what you need to do in order to remove IE from windows and we can reverse use this list of files to integrate it back - http://www.boot-land.net/forums/?showtopic=5066

On the list there are a lot of OCX files that we could also try with the option to install at build time to see how it goes. Look on the explorer script for the syntax example.

CODE
actxprxy.dll
asctrls.ocx
atl.dll.lnk
browsewm.dll
cdfview.dll
ckcnv.exe
cryptdlg.dll
cryptext.dll
cryptnet.dll
csseqchk.dll
dispex.dll
dxtrans.dll
hlink.dll
homepage.inf
ie4uinit.exe
ieakeng.dll
ieaksie.dll
ieakui.dll
iedkcs32.dll
iepeers.dll
iesetup.dll
imgutil.dll
initpki.dll
inseng.dll
isign32.dll
jobexec.dll
jscript.dll
jsproxy.dll
licmgr10.dll
mobsync.dll
mobsync.exe
msencode.dll
msidle.dll
msieftp.dll
msnsspc.dll
msr2c.dll
msr2cenu.dll
msrating.dll
mssign32.dll
mstime.dll
msxml.dll
msxml3.dll
occache.dll
plugin.ocx
pngfilt.dll
proctexe.ocx
regwiz.exe
regwizc.dll
scrobj.dll
sendmail.dll
simpdata.tlb
sysinv.dll
t2embed.dll
tdc.ocx
webcheck.dll
xenroll.dll
iexplore.exe


--------------------
+Quote Post
post Sep 29 2008, 07:20 AM
Post #9
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


QUOTE (Nuno Brito @ Sep 29 2008, 04:40 PM) *
btw: Can you post the script that you're using?

http://livexp.boot-land.net/LiveXP/Basic/S...Explorer.Script


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Sep 29 2008, 07:34 AM
Post #10
Nuno Brito
Platinum Member   ******
Group: .script developer

  Joined: 13-July 06 From: Coimbra

Posts: 7,685
Thank(s): 311


Portugal


Hi Galapo - good morning!

Thank you but I was talking about the IE script or does the explorer script comes with IE support? huh.gif

They do however seem to share an awful lot of inter-dependencies, please excuse me if my previous post wasn't very clear, I appreciate your help.

smile.gif


--------------------
+Quote Post

4 Pages V   1 2 3 > » 
Reply to this topic
2 User(s) are reading this topic ()





Collapse

  Topic Replies Topic Starter Views Last Action
No New Posts Registry parrameters
0 Résiliences 72 18th November 2009 - 10:13 AM
Last post by: Résiliences
No New Posts registry restore wizard
wizard
5 twindude 1,370 13th May 2009 - 12:55 AM
Last post by: Lancelot
No New Posts Registry entries continuesly deleted. HELP!!!
7 MedEvil 970 14th March 2009 - 04:48 PM
Last post by: MedEvil
No New Posts Registry settings to modify certain behaviors of windows.
direct download of .reg files.
0 Nuno Brito 664 16th January 2009 - 12:51 AM
Last post by: Nuno Brito
No New Posts Registry Key querie
Can anyone help?
6 ispy 1,718 5th July 2008 - 08:18 PM
Last post by: ispy


Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum