IPB

Welcome Guest ( Log In | Register )

Recommended
BootDisk.com

Active Users

3 Pages V   1 2 3 >  
Reply to this topicStart new topic
Is there a idiot-proof video tutorial available ?
sanbarrow
post Sep 24 2008, 06:31 PM
Post #1


Advanced Member
***

Group: Developer
Posts: 289
Thank(s): 11
Joined: 13-October 06
From: Germany - Sauerland
Member No.: 755



Is there a idiot-proof video tutorial available that explains how to build a default LiveXP ?

I just tried latest 75 beta but don't get further than

CODE
Generated by psc program 'WBVerify' version 2.2.0
Date: 2008-Sep-24 20:15:49

[Counts]
Missing=0
Obsolete=0
Errors=1
Warnings=4

Errors:
"When excluding MiscSettings.Script and FixShellWinlogon.Script, you must uncheck 'Don't set Explorer as shell' in Explorer.Script"
Warnings:
Problem with line: Call "WBVersion" (Build Model,075);
Problem with line: Call "WBVersion" (Copy and Expand files,071.03);
Problem with line: Call "WBVersion" (ImDisk,071.03);
Problem with line: Call "WBVersion" (Explorer,071.03);



(IMG:../forums/style_emoticons/default/frusty.gif)

Ulli
Go to the top of the page
 
+Quote Post
Nuno Brito
post Sep 24 2008, 07:06 PM
Post #2


Advanced Member
***

Group: .script developer
Posts: 6,137
Thank(s): 127
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


Well, on this case you might need to read the message that was outputted -
"When excluding MiscSettings.Script and FixShellWinlogon.Script, you must uncheck 'Don't set Explorer as shell' in Explorer.Script"


I would suspect that you unchecked a lot of scripts inside the Basic folder.

To get things working again - uncheck all possible scripts and click again on the "Basic" folder checkbox to select all scripts and disable any interferences.

You might also be interested in setting up some scripts on the Finish folder that create the ISO and run it on the emulator to check results.

Please reply back.

-----

If all goes wrong - download again a fresh copy - something I've also seen in the past is when a user tries to select what he thinks that is necessary to build a project from the Download Center and then leaves out essential scripts for some functions. Better use the recommended or minimum profile as it selected automatically for the first time you download the project files.

Then it should be safe to build a good project or add/remove scripts you find necessary.

(IMG:../forums/style_emoticons/default/smile.gif)
Go to the top of the page
 
+Quote Post
Lancelot
post Sep 24 2008, 07:09 PM
Post #3


Bug Catcher
***

Group: Advanced user
Posts: 675
Thank(s): 48
Joined: 8-May 08
Member No.: 15,072


Turkey


Error verify.log reason:
when you make changes that dont suit (that will cause livexp malfunction if build made), verify warn you with giving required information, as user should remember what he/she changes he/she should change back.

here is an advice for warning, i hope it helps:
Enable: Basic-->Build-->Shells-->Explorer Tweaks-->MiscSettings.Script
ps: as far as i know when livexp downloaded as default there shouldnt be this kind of warnings unless user change an option.



video tutorial:
i dont know if available, but i hope this tutorial help:

1st method:
download file from here,
http://winbuilder.net/download.php?view.8
and extract it to a folder like
C:\winbuilder
so winbuilder.exe is in folder like this:
C:\winbuilder\winbuilder.exe

2nd method:

Download WinBuilder075_Beta5.zip from here:
http://winbuilder.net/download.php?view.34

put WinBuilder.exe in a folder:
Ex:
C:\winbuilder\

double click WinBuilder.exe, go to download section (it should be default)
only check livexp.boot-land.net in server list, uncheck others
choose complete (my choice)
start download

After download finishes, click big blue Play button without changing any option
Everthing should work.




I hope these help
Go to the top of the page
 
+Quote Post
sanbarrow
post Sep 24 2008, 07:29 PM
Post #4


Advanced Member
***

Group: Developer
Posts: 289
Thank(s): 11
Joined: 13-October 06
From: Germany - Sauerland
Member No.: 755



I did not uncheck anything - other than Reactos.
I am just desparately trying to get any results at all so I tried to go with defaults.

No way.

After first attempt I tried again - this time with Reactos enabled and it even started to build but later aborted and winbuilder said it could not unload hive.

Go to the top of the page
 
+Quote Post
psc
post Sep 24 2008, 08:03 PM
Post #5


Guru
***

Group: .script developer
Posts: 5,404
Thank(s): 83
Joined: 14-July 06
From: Korschenbroich
Member No.: 3


Germany


QUOTE (sanbarrow @ Sep 24 2008, 08:31 PM) *
Is there a idiot-proof video tutorial available that explains how to build a default LiveXP ?

I just tried latest 75 beta but don't get further than

CODE
Generated by psc program 'WBVerify' version 2.2.0
Date: 2008-Sep-24 20:15:49

[Counts]
Missing=0
Obsolete=0
Errors=1
Warnings=4

Errors:
"When excluding MiscSettings.Script and FixShellWinlogon.Script, you must uncheck 'Don't set Explorer as shell' in Explorer.Script"
Warnings:
Problem with line: Call "WBVersion" (Build Model,075);
Problem with line: Call "WBVersion" (Copy and Expand files,071.03);
Problem with line: Call "WBVersion" (ImDisk,071.03);
Problem with line: Call "WBVersion" (Explorer,071.03);



(IMG:../forums/style_emoticons/default/frusty.gif)

Ulli

For the moment, forget the warnings.
For me they are still a bit of (IMG:../forums/style_emoticons/default/wodoo.gif) . They usually appear in LineXP on the very first run of a project. And I did not catch the reason until now.
But they are warnings only, and w/o an error the project would continue to build.

The 'error':
By the developer intentionally has been decided that your active configuration cannot run.
I think the reason is
  • In MiscSettings you can define PELoader as shell which starts Explorer.
  • I do not know FixShellWinlogon, but I think, here is a similar condition.
  • If both are unchecked and you check 'Don't set Explorer as shell', you have no shell that could run.
Verify errors correctly!

Peter
Go to the top of the page
 
+Quote Post
Lancelot
post Sep 24 2008, 08:11 PM
Post #6


Bug Catcher
***

Group: Advanced user
Posts: 675
Thank(s): 48
Joined: 8-May 08
Member No.: 15,072


Turkey


please follow try my previous post advices

it is obvious that you uncheck FixShellWinlogon.Script as it is checked default when downloaded.
Go to the top of the page
 
+Quote Post
amalux
post Sep 24 2008, 08:45 PM
Post #7


bug-catcher
***

Group: Tutorial Writer
Posts: 715
Thank(s): 54
Joined: 1-February 07
From: California
Member No.: 2,966


United States


Hi Sanbarrow,

Not video but download, extract and run should get you a working, basic LiveXP (IMG:../forums/style_emoticons/default/wink.gif)
Go to the top of the page
 
+Quote Post
Nuno Brito
post Sep 24 2008, 09:11 PM
Post #8


Advanced Member
***

Group: .script developer
Posts: 6,137
Thank(s): 127
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


You asked for a video, here is one.. (IMG:../forums/style_emoticons/default/smile.gif)


I remember some time ago that you also posted some similar difficulties but never replied back when we were trying to help. You were trying to use C:\Windows as source to build VistaPE or something similar, do you remember? (IMG:../forums/style_emoticons/default/huh.gif)


QUOTE
After first attempt I tried again - this time with Reactos enabled and it even started to build but later aborted and winbuilder said it could not unload hive.


Then there was also another issue reported by you that we concluded you were setting up the Path for the VistaPE project and then tried to build LiveXP with no good results (since LiveXP had no source windows selected).

To make things clear, wb works with multiple projects that are all visible on the main view. You will need to select a script from the project that you want to run before clicking on the Blue Play button. You can also only use one project at a time to avoid any confusions like before.


--------------

As other suggested, I would recommend

- Start from a clean folder as seen on the video.
- Use the latest stable wb version (no need to jump onto the freshier beta for the moment)
- Only select the LiveXP server (VistaPE and everything else goes unselected from the server list)
- Use the default "Recommended" or select "Minimal" to save some bandwidth
- After download click on the Big Blue Play Button - it will start the path wizard where you will choose your Windows XP/2003 Install CD files (on disk or CD)

See the results.

This is all described on the documentation, read here - http://winbuilder.net/help/#Installing

If you know how to build a bartPE then believe me that it is surely easier to build a liveXP, if you don't know how to use the download center from winbuilder.net to download a full zipped file with all minimal scripts inside and get a more "bart" user experience.


-------

Relax because it has been tested by thousands of users before you and it is not complicated in the large majority of cases.

Take your time, breathe deeply and look closely to each step that you're doing on the download center before you click on anything.

(IMG:../forums/style_emoticons/default/smile.gif)
Go to the top of the page
 
+Quote Post
sanbarrow
post Sep 24 2008, 09:22 PM
Post #9


Advanced Member
***

Group: Developer
Posts: 289
Thank(s): 11
Joined: 13-October 06
From: Germany - Sauerland
Member No.: 755



QUOTE
it is obvious that you uncheck FixShellWinlogon.Script as it is checked default when downloaded.


No - I did not uncheck that option. I do not even know where to do that !

Summary of one wasted afternoon:

I tried 5 builds.
First didn't even start.
Cleaned up and started from scratch.
Enabled reactos this time - build process runs but fails with unload hive issue.
Start from scratch again.
Followed Peters tip and found the setting to uncheck 'Don't set Explorer as shell' in Explorer.Script.
Next build really worked and I got a booting iso in qemu.
Tried to add VMplayer or Converter or OffLineSysPrep - ??? don't found anything.
Ok - lets see if a ramloading build can be created.
Enabled BootSDI script.
Build process starts - it even creates a image but no final iso - error message: can't remove vistape.vmx !!!
Looked at the iso-out dir again cause I wanted to look at the one working iso again but it was deleted ...


If I were a first time user trying to make a LiveXP for the first time I would be completely (IMG:../forums/style_emoticons/default/ranting2.gif)

Suggestion:

split winbuilder in some canned builds that come with working defaults.

Remove 90% of the options from the default gui - and put that into an advanced tab.
Make an idiot-wizard that walks the noob through this questions:


Hi -
do you want VistaPE, LiveXP, Reactos, ... ? Select one ...
Where are your sources ? ...
Do you need special drivers ? [No] or yes - if yes - open the drivers tab
Do you want to look at the app-scripts available ? [No] or yes - if yes - open the app-scripts tab
Do you want a standard CD ? [yes] or no - if yes - create a standard iso
Do you want a ramloading CD ? [yes] or no - if yes create a ramloading build using your bootSDI or whatever tricks you have
Do you want to test in Qemu ? [no] or yes - if yes run in qemu
Do you want to test in VMware ? [no] or yes - if yes run in vmware

Congrats - the results are here - or give errors

Don't get me wrong - no offense intended - I guess you just have a different target audience.

Ulli
Go to the top of the page
 
+Quote Post
psc
post Sep 24 2008, 09:24 PM
Post #10


Guru
***

Group: .script developer
Posts: 5,404
Thank(s): 83
Joined: 14-July 06
From: Korschenbroich
Member No.: 3


Germany


QUOTE (Nuno Brito @ Sep 24 2008, 10:11 PM) *
You asked for a video, here is one.. (IMG:../forums/style_emoticons/default/smile.gif)

I remember some time ago that you also posted some similar difficulties but never replied back when we were trying to help. You were trying to use C:\Windows to build VistaPE or something similar, do you remember? (IMG:../forums/style_emoticons/default/huh.gif)

--------------

As other suggested, I would recommend

- Start from a clean folder as seen on the video.
- Use the latest stable wb version (no need to jump onto the freshier beta for the moment)
- Only select the LiveXP server (VistaPE and everything else goes unselected from the server list)
- Use the default "Recommended" or select "Minimal" to save some bandwidth
- After download click on the Big Blue Play Button - it will start the path wizard where you will choose your Windows XP/2003 Install CD files (on disk or CD)

See the results.

This is all described on the documentation, read here - http://winbuilder.net/help/#Installing

If you know how to build a bartPE then believe me that it is surely easier to build a liveXP, if you don't know how to use the download center from winbuilder.net to download a full zipped file with all minimal scripts inside and get a more "bart" user experience.


-------


Relax because it has been tested by thousands of users before you and it is not complicated in the large majority of cases.

Take your time, breathe deeply and look closely to each step that you're doing on the download center before you click on anything.

(IMG:../forums/style_emoticons/default/smile.gif)

Sorry Nuno, I have to contradict.

The actual reality is different (and could / should / must be changed).

I did a download of a fresh (recommended) LiveXP, defined the source and started the build.
I got the Verify error Ulli described in his first post.

As experienced user I checked the MiscSettings script.
Here the first trap for an unexperienced user: He will need several posts in the forum to get the partial solution.

Then I restarted the build.
It ran well until it came to the Sysprep script.
After 30 minutes Of 'nothing happens' I stopped.
But on my surprise, the 'CreateMassStorageData.exe' icon remained in the tray for another 20 minutes until it disappeared.

Currently I'm building for the third time and I will not stop before one hour ...

Maybe that the mass storage scripts need so much time, but then it is not sufficient to write in the interface something about 'Be patient'.
Here should be 'Maybe that you have to wait for one hour or longer'

But better should be to exclude these scripts from the 'recommended' download or at least to uncheck them in the default build.

Peter
Go to the top of the page
 
+Quote Post
« Next Oldest · nativeEx & LiveXP · Next Newest »
 

3 Pages V   1 2 3 >
Fast ReplyReply to this topicStart new topic
3 User(s) are reading this topic (3 Guests and 0 Anonymous Users)
0 Members:

 

Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum

RSS Lo-Fi Version Time is now: 12th October 2008 - 09:02 AM

W3C XHTML • © 2008 Boot Land • All rights reserved • W3C CSS