IPB

Welcome Guest ( Log In | Register )

Recommended
BootDisk.com

Active Users

4 Pages V   1 2 3 > »   
Reply to this topicStart new topic
grub4dos-0.4.4 final will come soon, Please test the latest build and report problems.
tinybit
post Sep 22 2008, 02:25 AM
Post #1


Advanced Member
***

Group: Developer
Posts: 172
Thank(s): 8
Joined: 14-August 07
Member No.: 10,098


China


It is possible to release 0.4.4 final at the end of September. Please test the latest build right now at http://grub4dos.nufans.net/

You may report any problems here.

Thanks.


Go to the top of the page
 
+Quote Post
kDn
post Sep 24 2008, 07:39 AM
Post #2


Newbie
*

Group: Members
Posts: 8
Thank(s): 0
Joined: 11-August 08
Member No.: 17,298


Ukraine


Version: grub4dos-0.4.4-2008-09-21.zip
Currently not working:
...
initrd /boot/slax-initrd.gz
...

and

...
initrd /boot/bt3-initrd.gz
...

for Slax & BackTrack3:

with error:

Uncompressing Linux
crc error
--System halted

If comment splashimage lines all work fine. Also all work in version 0.4.3 with splashimage. More info in this thread.


ChangeLog_GRUB4DOS.txt:
2008-09-21 fixed memory conflicts between graphics mode and linux kernel. - What its mean?

And how use this?:
2008-09-07 title delimitors(or comments) can be used in menu now.
Go to the top of the page
 
+Quote Post
ctmag
post Sep 24 2008, 08:29 AM
Post #3


Advanced Member
***

Group: .script developer
Posts: 424
Thank(s): 20
Joined: 19-May 08
Member No.: 15,320


Germany


works fine for me with vistape12 and iso boot of partedmagic

also would like to know how to use new features...
Go to the top of the page
 
+Quote Post
kDn
post Sep 25 2008, 06:11 PM
Post #4


Newbie
*

Group: Members
Posts: 8
Thank(s): 0
Joined: 11-August 08
Member No.: 17,298


Ukraine


Version: grub4dos-0.4.4-2008-09-25.zip

BackTrack3 fully starts with active splashimage line. I don't have Slax at that moment, but I think there is no problem to start it. Thanks a lot. (IMG:../forums/style_emoticons/default/thumbup.gif)
Go to the top of the page
 
+Quote Post
ireneuszp
post Sep 28 2008, 10:50 PM
Post #5


Member
**

Group: Advanced user
Posts: 22
Thank(s): 1
Joined: 29-September 06
Member No.: 553


Poland


Currently not working:

CODE
title Microsoft Windows Vista/Longhorn Boot Manager (vbootmgr.img)
map --mem=-2880 (hd0,0)/vbootmgr.img (fd0)
map --hook
chainloader (fd0)+1
rootnoverify (fd0)
map --floppies=1
boot


(IMG:../forums/style_emoticons/default/mad.gif) (IMG:../forums/style_emoticons/default/sad.gif)
Go to the top of the page
 
+Quote Post
gomjh
post Oct 1 2008, 10:12 PM
Post #6


Member
**

Group: Members
Posts: 17
Thank(s): 0
Joined: 8-September 07
Member No.: 10,528


United States


This may sound weird, but I'm using grub.exe from a USB Stick running DOS to load VistaPE. On one of the new Dell E6400 notebooks with the Intel video option this works perfectly. However, when I try on an E6400 with the NVIDIA video (same Intel chipset though) I get the following error from grub.exe:

Failure restore ROM INT 0x15 vector. Unsupported DOS, device driver, or TSR.

However, if I load smartdrv immediately before running grub.exe the issue does not occur. I can use this as a workaround. However, I also have a CD-based system that uses grldr as the MBR and loading smartdrv is not an option to workaround this issue. It has the same error message when booting to the CD.

The weirdest part for me is that this is only occurring when the video option is different.
Go to the top of the page
 
+Quote Post
tinybit
post Oct 2 2008, 03:58 AM
Post #7


Advanced Member
***

Group: Developer
Posts: 172
Thank(s): 8
Joined: 14-August 07
Member No.: 10,098


China


QUOTE (ireneuszp @ Sep 28 2008, 10:50 PM) *
Currently not working:

CODE
title Microsoft Windows Vista/Longhorn Boot Manager (vbootmgr.img)
map --mem=-2880 (hd0,0)/vbootmgr.img (fd0)
map --hook
chainloader (fd0)+1
rootnoverify (fd0)
map --floppies=1
boot


(IMG:../forums/style_emoticons/default/mad.gif) (IMG:../forums/style_emoticons/default/sad.gif)


Try the latest once more please. If still unresolved, please tell which versions ever worked. If no versions ever worked, please describe details of the failure.

@gomjh

You didn't tell which version you were using, gomjh. Please try the latest. If still unlucky, please have a detailed description about the issue. Post contents of CONFIG.SYS and AUTOEXEC.BAT. And which DOS version, please?

Go to the top of the page
 
+Quote Post
kDn
post Oct 2 2008, 06:35 AM
Post #8


Newbie
*

Group: Members
Posts: 8
Thank(s): 0
Joined: 11-August 08
Member No.: 17,298


Ukraine


to tinybit

Who is looking for, he will. (IMG:../forums/style_emoticons/default/smile.gif)
I read your Chinese forum and found a useful opportunity, such as (2008-09-07 title delimitors(or comments) can be used in menu now.):

CODE
title --- Comment Line ---
help


In my humble opinion needs to be made to the file grub4dos-0.4.4\README_GRUB4DOS.txt as an example of use.
Thanks.
Go to the top of the page
 
+Quote Post
ctmag
post Oct 2 2008, 09:00 AM
Post #9


Advanced Member
***

Group: .script developer
Posts: 424
Thank(s): 20
Joined: 19-May 08
Member No.: 15,320


Germany


i have problem with the timeout (seems to default to 10 seconds even when i set 30) with the curren (02-10-08) version

in 01-10-08 it works ok
Go to the top of the page
 
+Quote Post
tinybit
post Oct 2 2008, 01:05 PM
Post #10


Advanced Member
***

Group: Developer
Posts: 172
Thank(s): 8
Joined: 14-August 07
Member No.: 10,098


China


QUOTE (ctmag @ Oct 2 2008, 09:00 AM) *
i have problem with the timeout (seems to default to 10 seconds even when i set 30) with the curren (02-10-08) version

in 01-10-08 it works ok


Really? Oct-2 only changed probe_int compared to Oct-1 and so it could only affect grub.exe. Please check the case again, because it does not seem to be possible.
Go to the top of the page
 
+Quote Post
« Next Oldest · Grub4dos · Next Newest »
 

4 Pages V   1 2 3 > » 
Fast ReplyReply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 

Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum

RSS Lo-Fi Version Time is now: 23rd October 2008 - 10:04 AM

W3C XHTML • © 2008 Boot Land • All rights reserved • W3C CSS