IPB

Welcome Guest ( Log In | Register )

Recommended
BootDisk.com

Active Users

2 Pages V  < 1 2  
Reply to this topicStart new topic
Diskpart Error with VistaPE, Error using command "Create Partition Primary"
JonF
post Sep 4 2008, 05:01 PM
Post #11


Advanced Member
***

Group: Advanced user
Posts: 382
Thank(s): 42
Joined: 7-January 07
From: Boston, MA
Member No.: 2,319


United States


QUOTE (ludovici @ Sep 4 2008, 10:19 AM) *
Thanks Jaclaz, where is the [ codebox ] [ /codebox ] tags that provide horizontal and vertical scrolling bars? (Wrap in code tags, insert list or other...)

There is no button for codebox tags. You must actually type them!!1!1!!eleventy-one!
Go to the top of the page
 
+Quote Post
lills1
post Sep 22 2008, 02:28 PM
Post #12


Member
**

Group: Members
Posts: 15
Thank(s): 0
Joined: 3-September 08
Member No.: 17,882


United Kingdom


QUOTE (ludovici @ Sep 4 2008, 02:19 PM) *
sorry (IMG:../forums/style_emoticons/default/merc.gif) I understand (IMG:../forums/style_emoticons/default/dubbio.gif)
Thanks Jaclaz, where is the [ codebox ] [ /codebox ] tags that provide horizontal and vertical scrolling bars? (Wrap in code tags, insert list or other...)
lills1, Have you resolved your problem ? (IMG:../forums/style_emoticons/default/idea.gif)


ludovici

Sorry for the late reply, I have just got back from holiday. If I go into Computer Management\Services, no services are listed :-(

Go to the top of the page
 
+Quote Post
ludovici
post Sep 22 2008, 04:00 PM
Post #13


Advanced Member
***

Group: Advanced user
Posts: 58
Thank(s): 2
Joined: 1-November 07
Member No.: 11,607


France


Hello Men (IMG:../forums/style_emoticons/default/wink.gif)
Ctmag is right, normally this service should e running.
But if you have not this service listed, you can copy/paste my additions of one script in a script (exemple: CPL...) and the Virtual disk service will be listed...
Good Luck
Go to the top of the page
 
+Quote Post
lills1
post Sep 23 2008, 10:12 AM
Post #14


Member
**

Group: Members
Posts: 15
Thank(s): 0
Joined: 3-September 08
Member No.: 17,882


United Kingdom


QUOTE (ludovici @ Sep 22 2008, 04:00 PM) *
Hello Men (IMG:../forums/style_emoticons/default/wink.gif)
Ctmag is right, normally this service should e running.
But if you have not this service listed, you can copy/paste my additions of one script in a script (exemple: CPL...) and the Virtual disk service will be listed...
Good Luck


Thanks for your help everyone. I started a new VistaPE project from scratch and it appears to have fixed the problem, diskpart works fine now. I must have done something in the config somewhere that screwed it up
Go to the top of the page
 
+Quote Post
lills1
post Sep 26 2008, 10:18 AM
Post #15


Member
**

Group: Members
Posts: 15
Thank(s): 0
Joined: 3-September 08
Member No.: 17,882


United Kingdom


I figured out what caused the diskpart problem.

When VistaPE didn't include devcon.exe, this would cause a slow pnp detection, and everything worked fine. As soon as I added devocn.exe to VistaPE, it caused a fast pnp detection and caused the diskpart problems to occur. After a bit of investigation I found that the fast pnp detection didn't run volume.inf and this was the source of the problem.

What I did to fix the issue was to use Mustang's "AddDrivers.script" and added volume.inf to the ISO using peimg.

Hope this helps anyone else who has had this problem.

If anyone knows why fast pnp detection omits volume.inf, let me know.
Go to the top of the page
 
+Quote Post
ctmag
post Sep 26 2008, 10:45 AM
Post #16


Advanced Member
***

Group: .script developer
Posts: 337
Thank(s): 14
Joined: 19-May 08
Member No.: 15,320


Germany


thanks for the info...
Go to the top of the page
 
+Quote Post
« Next Oldest · VistaPE · Next Newest »
 

2 Pages V  < 1 2
Fast ReplyReply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 

Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum

RSS Lo-Fi Version Time is now: 9th October 2008 - 03:55 AM

W3C XHTML • © 2008 Boot Land • All rights reserved • W3C CSS