Hello dear guest!

Why not join our boot disk community? So do it. Life's short!

  - You get free access to our newsletter with all the interesting buzz about boot disks
  - We share publicity revenue with everyone who wishes to participate at the forums
  - Publicity is never, never, never displayed to members (along with many other cool things)
http://boot-land.net/register

184 Pages V  « < 70 71 72 73 74 > »   
Reply to this topic
 LiveXP -- Anything & Everything, Look only Post #1 and Last Posts of this topic
Rating 3 V
post Oct 31 2008, 08:00 PM
Post #711
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


QUOTE (JonF @ Nov 1 2008, 01:04 AM) *
Here's a questiion that puzzles me:

Why is there a FixShellWinlogon.Script and a MiscSettings.Script under Explorer Tweaks? They appear to do about the same thing but in slightly differnt ways. Why distribute both as part of the project?


They are currently distributed for just that reason: they do much the same things but in different ways.

Historically, MiscSettings.Script has been the script which has done the work here. However, I personally am preferring FixShellWinlogon.Script for layout/understandability etc. But since some users may have gotten used to using or prefer MiscSettings.Script, I have continued to supply it also.

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Oct 31 2008, 08:05 PM
Post #712
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


QUOTE (psc @ Oct 31 2008, 09:53 PM) *
To write in an installation script any UserAssist line is senceless.

For most apps, yes. But there are some rare cases where if some particular UserAssist entries don't exist, the app fails to initialise. I haven't tested whether this particular entry is needed by TI. I basically just copied Thuun's script to api, but must have uncommented the line (but it's a long time ago now and I forget the reason).

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Oct 31 2008, 08:09 PM
Post #713
psc
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


Germany


QUOTE (Galapo @ Oct 31 2008, 09:00 PM) *
They are currently distributed for just that reason: they do much the same things but in different ways.

Historically, MiscSettings.Script has been the script which has done the work here. However, I personally am preferring FixShellWinlogon.Script for layout/understandability etc. But since some users may have gotten used to using or prefer MiscSettings.Script, I have continued to supply it also.

Regards,
Galapo.

If FixShellWinlogon does the same and more than MiscSettings, you should take MiscSettings from the project.

I remember that I some weeks ago suggested fxscrpt to combine his bug fix with MiscSettings.

I'm sure that Holger does not feel affronted when his script disappears, which has been useful for a long time, but now has a powerful child.

The king is dead. It lives the king!

Maybe, in memoriam to the old king, fxscrpt agrees that the combined script is still called MiscSettings and is just a newer version of this script.


Peter


--------------------
Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Oct 31 2008, 08:53 PM
Post #714
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


Sounds good to me. Let's see what fxscrpt says.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Oct 31 2008, 10:03 PM
Post #715
fxscrpt
Frequent Member   ***
Group: .script developer

  Joined: 15-September 08
Posts: 347
Thank(s): 62


Germany


QUOTE (psc @ Oct 31 2008, 09:09 PM) *
I remember that I some weeks ago suggested fxscrpt to combine his bug fix with MiscSettings.

I did it at your suggestion. (version 21)
QUOTE (Galapo @ Oct 31 2008, 09:53 PM) *
Sounds good to me. Let's see what fxscrpt says.

I agree with every solution. even to have both (if absolutely necessary)


there are very small differences:
in FixShellWinlogon minlogon and shelllogon can be mixed with any shell loader.
(minlogon/peloader mix does not work by design)

in MiscSettings (v.21) 'restart shell for Peloader' was added.
this option is not implemented in FixShellWinlogon because
i stopped development.
naturally the option (btw: for any shell loader) can be added to FixShellWinlogon.

Peter
+Quote Post
post Nov 1 2008, 03:01 AM
Post #716
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


QUOTE (Lancelot @ Oct 31 2008, 11:25 PM) *
or maybe a box like:
Use Custom Preferences.ini

Done!

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Nov 1 2008, 10:32 PM
Post #717
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


@fxscrpt

I find this in livexp registry, it was not there before (i checked a long time ago before)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x]
"EnforcedDirectories"="%WINDIR%;%ProgramFiles(x86)%\\Movie Maker"

Here are scripts i enable,

Define Fundamentals Version[36]
VerifyMacros Version[34]
Verify Project Version[38]
Retrieve Project Info Version[14]
Make directories Version[8]
HoJoPE Hives Factory Version[51]
Build Model Version[57]
Copy and Expand files Version[20]
TempPE Version[4]
Explorer Version[47]
ImageCreator Version[9]
ImDisk Version[20]
Winlogon / Shell Version[3]
driverSigning Version[8]
Notepad Version[10]
Registry Editor Version[10]
LSI plus Bus Logic - SCSI drivers for Vmware Version[1]
locale Additions Version[7]
Create ISO Version


This doesnt effect anything (for now), i only noticed. Maybe a sign of a small devil, better to kill before it gets bigger. smile.gif
I hope you have a idea, if not no problem for now.


--------------------
+Quote Post
post Nov 1 2008, 10:55 PM
Post #718
Lancelot
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Turkiye


@galapo

can we have "Use Dll init at boot time" for VMWarePlayerWorkstation.Script ?

I made somethings, but needs your approval

i add this to interface section
pCheckBox4="Use Dll init at boot time",1,3,27,52,136,18,True

i change these 2 lines
Run,%OLESupportScript%,Register-DLL,atl.dll,devmgr.dll,mlang.dll,msvbvm60.dll,mycomput.dll,themeui.dll,comdlg32.
ocx,mscomctl.ocx,richtx32.ocx
Run,%OLESupportScript%,Install-DLL,mshtml.dll,urlmon.dll
to
If,%pCheckBox4%,Equal,False,Run,%OLESupportScript%,Register-DLL,atl.dll,devmgr.dll,mlang.dll,msvbvm60.dll,mycomput.dll,themeui.dll,comdlg32.
ocx,mscomctl.ocx,richtx32.ocx
If,%pCheckBox4%,Equal,False,Run,%OLESupportScript%,Install-DLL,mshtml.dll,urlmon.dll
If,%pCheckBox4%,Equal,True,Run,%ScriptFile%,dllinitboottime

i add this section

CODE
[dllinitboottime]
RegHiveLoad,"WB-software","%TargetDir%\i386\system32\config\software"
RegWrite,"HKLM","0x2","WB-software\Microsoft\Windows\CurrentVersion\RunOnce","950","hiderun.exe#$s/w#$s#$pSystemRoot#$p\vmware_reg.cmd"
RegHiveUnLoad,"WB-software"
FileCreateBlank,%target_win%\vmware_reg.cmd
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\atl.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\devmgr.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\mlang.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\msvbvm60.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\mycomput.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\themeui.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\comdlg32.ocx",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\mscomctl.ocx",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s#$pSystemRoot#$p\system32\richtx32.ocx",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s/i#$s#$pSystemRoot#$p\system32\mshtml.dll",APPEND
TXTAddLine,%target_win%\vmware_reg.cmd,"#$pSystemRoot#$p\system32\regsvr32.exe#$s/s#$s/i#$s#$pSystemRoot#$p\system32\urlmon.dll",APPEND


I am not sure if i did everthing right and i am pretty sure somethings should be changed, i hope you like the idea?!


--------------------
+Quote Post
post Nov 2 2008, 01:05 AM
Post #719
fxscrpt
Frequent Member   ***
Group: .script developer

  Joined: 15-September 08
Posts: 347
Thank(s): 62


Germany


QUOTE (Lancelot @ Nov 1 2008, 11:32 PM) *
@fxscrpt

I find this in livexp registry, it was not there before (i checked a long time ago before)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x]
"EnforcedDirectories"="%WINDIR%;%ProgramFiles(x86)%\\Movie Maker"

Here are scripts i enable,

...
This doesnt effect anything (for now), i only noticed. Maybe a sign of a small devil, better to kill before it gets bigger. smile.gif
I hope you have a idea, if not no problem for now.

cheers.gif
because in HIVESFT.INF this line exists:
HKLM,"SOFTWARE\Microsoft\HTMLHelp\1.x","EnforcedDirectories",,"%WINDIR%;%ProgramFiles%\Movie Maker"
and HOJOPE does not 'convert' %ProgramFiles% to %programfiles%.
btw: maybe we have a working solution for dll registration soon. smile.gif
Peter


+Quote Post
post Nov 2 2008, 05:11 AM
Post #720
Galapo
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Australia


QUOTE (fxscrpt @ Nov 2 2008, 12:05 PM) *
btw: maybe we have a working solution for dll registration soon. smile.gif

Are you dangling a teaser? Good to hear!

Regards,
Galapo.


--------------------
galapo.boot-land.net
------
Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post

184 Pages V  « < 70 71 72 73 74 > » 
Reply to this topic
3 User(s) are reading this topic ()





Collapse

  Topic Replies Topic Starter Views Last Action
No New Posts LiveXP shutdown process
4 Arjun 382 9th November 2009 - 01:43 AM
Last post by: TheHive
No new Topic has attachmentsLiveXP Troubleshooting
Various questions and answers
92 JohnBug 8,397 29th October 2009 - 02:25 PM
Last post by: amalux
No New Posts Topic has attachmentsLiveXP WB078 Slow Load
64.4Mb ISO Slowly loading....*VIDEO*
11 dsolomon 941 20th October 2009 - 06:56 PM
Last post by: psc
No New Posts LiveXP Adding Driver?
6 Furgy 696 13th October 2009 - 11:30 AM
Last post by: Lancelot
No new Topic has attachmentsLiveXP not detecting Raid Controller
39 pantner 2,330 7th October 2009 - 04:22 AM
Last post by: Galapo


Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum