Hello dear guest!

Why not join our boot disk community? So do it. Life's short!

  - You get free access to our newsletter with all the interesting buzz about boot disks
  - We share publicity revenue with everyone who wishes to participate at the forums
  - Publicity is never, never, never displayed to members (along with many other cool things)

184 Pages V   1 2 3 > »   
Reply to this topic
 LiveXP -- Anything & Everything, Look only Post #1 and Last Posts of this topic
Rating 3 V
post Aug 11 2008, 09:16 AM
Post #1
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


This is a kind of "Bug Tracker" topic For LiveXP .
If you are a new user Please do not waste your time reading this topic cheers.gif
If you have a problem open a new topic at LiveXP section thumbup.gif thumbsup.gif thumbsup.gif

Hi Galapo, these are waiting your vacation end smile.gif

ExpEnvVar.exe bugy,
commas "," not processed right, this only cause icon error, nothing essential. wink.gif
check post 22 here http://www.boot-land.net/forums/index.php?...ost&p=84080
also post 29 - post 30

Welcome to the 1st main post,
When things here solved or added etc., it is deleted in 1st post, so dont surprise if it gets shorter smile.gif
When new things are found and documented it is added to 1st post, so dont surprise if it gets longer hyper.gif
As you already can create a new topic, You can also post any issue if you want to this topic.
(also issues are collected by me to this topic when noticed)

***I cant find time to check post #1, some of the things on post #1 maybe fixed in time, still this is a nice topic/archive to catch/clean/remember bugs and development notes about LiveXP.

------Master Issues------------------------
If "Master Issues" now empty, we are all happy roll1.gif

****Issue: Vista (i guess mostly x64)
"Driver Signature Enforcement" stops mounting utilities (ex: vdk.exe) prevent working. We need a creation of .img/.vmdk files with a way like wimpack without mounting.
Solution: Vista64 Users, disable "Driver Signature Enforcement", there is plenty of methods on net you can find with a quick google-fu

****Issue: fbwf upper limit (full) issue
when user uses all available space provided by fbwf, LiveXP lock down.
This is important for automatic AV updates after PE boots. A warning made here
*Probable Future solution: a monitoring tool that monitors fbwf and stops writing anymore file at a limit (say free space 3mb) (maybe another added feature for setresolution smile.gif )
*Solution for now: WARNING, do not use all space provided by fbwf smile.gif

****DEP: bootsdi-vdk
Windows DEP is not tolerant of WinBuilder and vdk. Switch off DEP and LiveXP builds OK. niche99 post26 probably warning for Vista Users
ps: xp-->no problem, 2k3-->set settings to xp settings, Vista-->switch off dep
Future hope of Solution:
I hope one day we will have a DEP checker

------Master Issues----------------END-----

****Issue: msi.script - Something missing - reported post 1097
QUOTE (Lancelot @ Feb 4 2009, 07:47 PM) *
something missing with msi.script (Projects\LiveXP\Basic\Shells\Addons), but WHAT????

Here is the test routine:
1) enable msi.script
2) enable fbwf or bootsdi
3) Download
Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) from here and add it to livexp cd.
4) in LivexP double click vcredist_x86.exe

ps: (maybe relevant maybe not, in my tests ScriptingCore.script , ScriptingSup.Script, mmc and dipe selected too)

to overcome for specific example, i manually extract vcredist_x86.exe so VCREDI~3.EXE went out. double clicking VCREDI~3.EXE gives same error.
Than i manually extract VCREDI~3.EXE and vcredist.msi+vcredis1.cab came out. double clicking vcredist.msi worked.
ps: also same issue happens with "Microsoft Visual C++ 2008 Redistributable Package (x86)_SP1"

probably in most .exe cases that installs .msi this error occurs, any idea for solution???????

edit: ps: "vcredist_x86.exe /q" works successfully.

Lancelot Personal TODO list:

**TODO: check how livexp works when source is xp64

**TODO: Finalize Batch script, check if bugy fixed described at post 1240 note starting with @Peter (psc) X 2

**TODO: Basic-Shells-Explorer.script ---> "Use DLL init at build time rather than at boot time" is checked
a verification needed ( info from post 1233 )
-Source CD language is different from host OS language
-Source CD architecture is different from host OS architecture
-In Explorer.script the checkbox "Use DLL init at build time rather than at boot time" is checked
than use dll init at build time should be unchecked
ps: post 1235
QUOTE (psc @ Mar 25 2009, 03:51 PM) *

Change the Explorer.Script's Verify item as you think how it is needed!
I'll copy the result into nativeEx_barebone.

**TODO: paraglider hwpnp request
post 1201 Paraglider can make a setting for hwpnp with a text on gui saying "Press 'Esc' to close Hwpnp" !?
note: fxscrpt solved the issue on LiveXP-hwpnp and updates made to hwpnp + xpnp aio script,
to reproduce the issue: enable hwpnp , disable xpnp-aio, disable qemu option at hwpnp, disable acpi on qemu
to reproduce the issue: disable hwpnp, enable xpnp-aio, disable acpi on qemu
(hwpnp 15 , xpnp-aio 35)

**TODO: wimpack
having fat option back (reason post 1241 )

**TODO: for create iso and bootsdi script
(System,SAVELOG, not available with wb076, first with wb077b1)
  If, ... ,ShellExecute,Open,%Tools%\mkisofs.exe ...
++also pack with .7z
7za ... %target_win%\logfile%myDate%.html ... %target_win%\logfile%myDate%.7z /// filedelete %target_win%\logfile%myDate%.html
ps: an example available at nativeex, dont forget to change %target_win%\logfile%myDate%.html

**TODO: change script.project interface (remember Nuno's advice)

**TODO: change scripts interface
Start Menu Folder (blank for default)
Start Menu Folder

**TODO: nic gpu script project (kare)

**TODO: prepare a tutorial to boot LiveXP from C: mentioned here at post 78 and at post 80

**TODO: script.project - Maybe "Clean Temporary Files" if exists automatically

**TODO: dotnet3 script or lodr pack with help from sanbarrow (post 487)
QUOTE (sanbarrow @ Feb 9 2009, 03:01 PM) *
I have a first experimental LODR-pack for dotnet3 working.

Translating this to the standards we discussed here is way beyond my skills.
Anyway - if anybody is interested in translating this to LiveXP I can try to explain.
The procedure for grabbing the required files is a nightmare.

Once created you need a wim about 170 Mb and about 30 Mb of free space in NTFS-formatted X:

**TODO: app script:
remind and test my request about StartMenu .lnk creation folder (Start Menu Root) post 341

**TODO: "DriverForge for DPS LAN support on LiveXP"
idea first introduced here
put option to start penetwork after adding lan (also sleep10 seconds before starting and no sleep when penetwork starts)

**TODO: BootScreen for LiveXP (changes required with createiso and bootsdi script)
Follow tutorial here and Take and edit Shrin's picture: How to place your own Boot screen in XP setup CD - Shrin
also remember old bartpe plugin picture when editing smile.gif.

**TODO: Read WinBuilder DBMS Beta Client Packages

**TODO_Personal: Verify special files
Verify files at startup to prevent user, expecially for setupldr.bin and ramdisk.sys for bootsdi and createiso (maybe size or version check for them, 2k3sp1 files are all same bytes) + fbwf with create iso (etc) Example

**TODO: Theme - I dont think it is possible but check this

**TODO: Script project
my wimL idea with optiononal LOD (first written in sanbarrow's topic)
QUOTE (Lancelot @ Jan 3 2009, 07:57 PM) *
It is nice to read nice things from you Peter,

Some more things about 'Midway' to clarify,

With 'Midway' i mean: this is not absolutely sanborrow's method, this is a method that will suit Nuno and Galapo's (and mine) concerns tu use LOD (+wimL)

And i highly believe, many things i wrote can be done automatically by api without changing a script a lot like FastStoneCapture.
With my idea only adding 2 (or 3) options to the begining of [process], and rest can be done by api
For wimL: 1 interface button and 1 line to the beginin process section for wimL -->will be enough for most scripts like FastStoneCapture--->rest can be done by api
For wimL+LOD: 1 interface button and [LODextra] section for creating .cmd file and related shortcuts for loading on demand

Maybe somebody who understands what i mean can post with better english, if nobody understands, than lets drink beer cheers.gif .

Anyway, smile.gif, i will be glad to be the first tester smile.gifsmile.gif for the result of work you will do with sanbarrow. Good luck thumbup.gif
QUOTE (Lancelot @ Jan 4 2009, 01:58 PM) *
Galapo, Peter

I cant use wimpack.exe on builds for now, but it is better to put half of my idea (the other half will be load on demand) (all idea is at post 23 and post 26) in a simple script
can you check this:


this is NOT a ready script, look two // MISSING - STAGE in script file

i hope it is more understandable now? what do you think ?
Galapo, Thank you for help by post 64
QUOTE (Galapo @ Jan 5 2009, 12:25 AM) *
Here's basic syntax for wimpack.exe:

wimpack.exe targetdir folder_in_targetdir_to_pack cmd_file system_exclude_file_list

Eg: wimpack.exe c:\target program c:\target\cmd.cmd none

Note: in targetdir a folder 'i386' must exist, to which the outputted WIM will be generated. cmd_file is necessary in this case only to avoid program error.
I need to figure out to pack with wim by using winbuilder, i love this idea but i will finish later ......
+++With Nuno's idea at post 54, unpacked files maybe kept in %GlobalTemplates%\wimlpack_Files\%scriptfilenamestr%_%scriptfileversion%\ folder

**TODO: Create ISO adding
An option to create a iso which works with ramdisk.sys method (iso in iso) for some purposes.
Reason: Currently with grub4dos we can boot this
title Start LiveXP_RAM.iso
find --set-root --ignore-floppies /LiveXP_RAM.iso
map /LiveXP_RAM.iso (hd32)
map --hook
chainloader (hd32)
It will be better to have also this
title Start LiveXP_RAM_ISO.iso
find --set-root --ignore-floppies /LiveXP_RAM.iso
map /LiveXP_RAM.iso (hd32)
map --hook
chainloader (hd32)

**TODO: Create ISO adding
*fbwf not start automatically option. Kare says acronis10ti needs 96mb, which results not working with 128mb ram computer when fbwf enabled (fbwf on boot+%25imdisk).
*a utility (or a set of shorcuts to start fbwf with different options (%10, %20, %30 .... )
*can fbwf be stopped and start

**TODO: Ramdrive
resize ramdrive, i guess increasin is not a problem
for decreasing maybe with an option saying "minimum as possible" which result with 5 mb space. My idea is creating a new ramdrive (ex: K:) with the size of B: + 5mb, than copy files to K:, remake B:, and copy files back to B:, remove K: (+maybe refresh shortcuts)

**TODO: A mini introduction to new users to show:
%target_win% %target_sys% %source_win% %source_sys% %GlobalTemp% %ProjectTemp% %GlobalTemplates%

**TODO: Reorganisation of scripts
kare's idea (sharing him) an extra in apps for essential scripts for optimal needs like:
penetwork, notepad, taskmanager, mmc, regedit, offbyone (for opening html files and minimal internet), addcmd utils, 16bit support and a very small picture viewer, maybe we can register some common picture extensions with FreeFSCapture (not sure)
This is also a good idea to say user "disable all apps script, and enable only apps\essential"

**TODO: Winbuilder script selection idea
when clicked on folder on winbuilder, it disables or enables all scripts. What about a mid option, example: imagine no scripts selected under a folder, clicking first will enable only scripts that have download level lower than 2, this will help a lot for commercial scripts. With 2nd click all scripts selected. If this idea okey than for commercial scripts enableing on 1st click can be availabe when required license exists.

**TODO: Reorganisation of scripts
Read Nuno's post and other posts

**TODO: post #997 dipe bug to kare (reported to kare, will be deleted from my todo list when done
QUOTE (dera @ Jan 5 2009, 07:53 PM) *
So have made a try with my Sigmatel once more:
using DrvImp.exe I have success only in that case if the extracted files of the driverpackage located in the right folder,
in my case it is '%ProgramFiles%\IDT\WDM'
if the files located in any different folder: DrvImp failed - copy the .ini files into system32 doesn't help.

DriverForge can successfully install the driver from any location - seems it is no matter where the files are located,
(the '%ProgramFiles%\IDT\WDM' is correctly created during the installation proces)

also have success not using DrvImp.exe or Driver Forge,
but simply updating the driver of an Unknown device via Device Manager
(Properties > Driver > Update Driver...)
pointing to the .inf
in this case also no matter where the files are located
(the '%ProgramFiles%\IDT\WDM' is correctly created during the installation proces)


****Suggestion: wimpack
-an option to create wims out of BootSDI.img without .vmdk (I need this once during tests with JonF)

****Suggestion: Login Picture for LiveXP
Maybe login picture for LiveXP can be good
but script method dont work because NTOSKRNL.EX but NTOSKRNL.EX recopied by some scripts
so maybe on bootsdi-createiso stages

Maybe we need a button on main screen to make a minimum build to satisfy the idea of Peter post 29 , another midway smile.gif

*********Suggestion - post 688 - 689 - 699
Shortly: Something needed for Vista Symbolic links and junctions to ease the access Vista disks using livexp
XP dont know which one is symbolic link and which on is not, also xp cant use the junction of vista
*->Maybe a command utility to show where folders are junked
*->Maybe an explorer (like A43) that has ability to show Vista Symblick links and junctions
Here are the utilites that i tried:
-Reads Vista JUNCTION successfully
-But NO Vista SYMLINKD folders with chain icon, or dont give info about SYMLINKD folders.
-vcredist_x86.exe for Vs2005 Sp1 required which we dont have a script for this yet
junction-shell-extensions -NO Vista compatible
ntfslinkext -NO Vista compatible
winbolic -NO Vista compatible when used in xp, and no practical usage
Mini info about 'symbolic link', 'hard link' , 'Directory Junction' from howtogeek

Java Runtime Environment

Wouldn't it better to have sharing->permission option for folders?

Wouldnt it be nice to see local area connections default seen on right low of screen like in moa
Look the movie here , there is 3 network shown on right bottom of corner, probably 2 for virtual machine 1 real.

Messenger 4.7 can be on livexp too, 4.7 is supported by microsoft for a long time as MS gave messenger 4.7 with xp cd.
i asked here http://www.boot-land.net/forums/?showtopic=5421 but no answer yet.
anybody have a messeger 4.7 plugin for bartpe?

netmeeting smile.gif, just for fun, nothing serious, i have emotinal feelings about netmeeting, it is still nice on lan, also nice for drawing pictures together over lan.

------End of post issues-----------------
(for some reasons, i put them in the end of post #1)

****Issue: 4 - !WBVerify.Script ( chair.gif Peter's script )
If a user forgets to show source and starts building with winbuilder, wb asks for source and user shows the source
wbverify dont understand this and gives this error
with 2nd run, this error dont happen anymore

****Issue: 4 - BuildModel.Script ( chair.gif Peter's script )
defined post 329
target is X:\ in both cases

****Issue: 4 - BuildModel.Script ( chair.gif Peter's script )
New SR option with build model not working (post 333)

****Issue: !WBVerify.Script ( chair.gif Peter's script )
Verify Should Check UAC on Vista machines to be sure UAC is enabled for winbuilder.exe
Solution Temporary: During tests Vista directly asked for UAC permission for winbuilder.exe which i press YES so no problem occured creating iso, i advice all users to give UAC permission smile.gif
Here is a note in bugtracker
Here are some links on net:

****Issue: BootSDI - Wimpack - !WBVerify.Script ( chair.gif Peter's script )
Verify Should Check "Driver Signature Enforcement" on Vista64 with a trial/test (test/trial because some other utilities may disable "Driver Signature Enforcement" by faking Vista64 that DSE is working )
Solution Temporary: I am sure Vista64 users can google-fu and find ways on internet to disable DSE
Here are some info:
*Press F8 on Windows boot load, you get Vista Advanced Boot Options, select “Disable Driver Signature Enforcement” to bypass driver signing check on vista

****Reminder: USB
u3-usb support--sth missing: http://www.boot-land.net/forums/index.php?showtopic=6495
I hope we can have tests with a usb device which one of our frequent user have

****Issue: Vista Format
behavior with vista format tool (vista 32bit) that causes wimpack stage fail (fixed with change on script) but still i dont know how to calculate when ntfs is choosen.
Look: post56 - post70 - post72 - post74
Solution Temp: Wimpack script now formats FAT32 as default so no problem for a new user. If someone who uses vistahostos and ntfs, than for now he should increase freespace in vmdk script till he get enough freespace.
++Galapo Post 972 to make fix on code

***Issue: Font support
I use english source, but i need turkish font support fully
Manual solution:
By dera's advice (post 246) i created a script for myself (i use xpsp2eng as source, turkish keyboard) by taking regs from a xpsp2x86 eng OS which is configured to use TR. Here it is (ONLY WHEN ENGLISH SOURCE USED to have TURKISH FONTS enabled): http://lancelot.winbuilder.net/5F_scriptsl...Eng-Font_TR.rar
Maybe an auto_clssupport script, and besides a manual one, Masters decide for more permenant solution rolleyes.gif
++we have hungary and cyrillic support scripts, better to unite all in one

***Issue: RestoreBase.Script SaveBase.Script ( chair.gif Peter's script )
A bug report from saydin77
i never use SaveBase.Script (or restore) , but looking inside the script i can confirm saydin77's findings.
here they are:
"use current build" works properly
"use predefined standard build" cause errors
in [do-list] section this fixes needed regedit -> regedit-api , taskman -> taskman-api
there are path changes for qEmuNIC_RTL8139, UniversalVideoDriver,VirtualBoxNIC_AMD_PCNET ...
2 variables dont work properly %PE_Programs% + (saydin77 dont remember the 2nd one)
and when restorebase used, the things that should be in "program files" are in basedir. (or restorebase.script directory)
Thanks to galapo, now there is "Create backup archive of Live XP" option, use this instead of RestoreBase.Script and SaveBase.Script.

***Issue: (as galapo wrote "it would require a re-write and change of logic by the imdisk driver" here no recent expectation for solution smile.gif , SetPageFile script will mostly suit demand for pagefile which will be nice to use essentially with pendisk)
how to make a page file with imdisk, so pagefile can created in ramdisk or bootsdi. (look Galapo's posts)
how to make a page file for livexp for the utilities that needs a pagefile --> look mini solution
maybe minimum 6mb, max(large number) of a pagefile under ramdrive (B:\) can be nice,
look link for the issue
also i tried SetPageFile1008.cab but couldnt suceed.
ps: you can try this script to see if pagefile works correctly. http://www.boot-land.net/forums/?showtopic=5493
For info about pagefile subject look:
post 102 Galapo
post 186 Galapo
mini solution:
SetPageFile script , works nice with realhd, but dont like to work with imdisk as galapo described in posts.
+ thunn wrote a script PePageFile.Script for pagefile, but it doesnt work with livexp 'cause of reason galapo described.
+ mounting images fail when images are in ramdisk, probably 'cause of reason galapo described.
+ Oleg gave info "The problem is that the ImDisk drive is not created early enough in the boot process to use the normal settings for pagefile." , also Oleg informed at swapadd topic, at post12 by Galapo and post13 by dog, it still fails to create pagefile on ramdisk with LiveXP.

***Issue (Minor) hostnic script ( chair.gif Peter's script )
hostnic script look post 218 (follow link), post 219, simply there should be something that should stop hostnic to install when there is no fbwf or bootsdi. Also there should be a warning in gui of hostnic. (like driver import pe script)

------End of post issues----------END----

***X64 Related

***IssueX64 "3 - hivesFactory.Script" ( chair.gif Peter's script ) - Have no effect on usage - post #717 and post #719
QUOTE (fxscrpt @ Nov 2 2008, 03:05 AM) *
QUOTE (Lancelot @ Nov 2 2008, 12:32 AM) *
I find this in livexp registry, it was not there before (i checked a long time ago before)
"EnforcedDirectories"="%WINDIR%;%ProgramFiles(x86)%\\Movie Maker"

because in HIVESFT.INF this line exists:
HKLM,"SOFTWARE\Microsoft\HTMLHelp\1.x","EnforcedDirectories",,"%WINDIR%;%ProgramFiles%\Movie Maker"
and HOJOPE does not 'convert' %ProgramFiles% to %programfiles%.

***IssueX64 !WBVerify.Script ( chair.gif Peter's script)
Read post 1055
should be sth like:
If,%cnt%,NotEqual,0,ShellExecuteex,"Hide","cmd.exe","/C %VerLog%"

***IssueX64 Minor - shortcut creation ( chair.gif Peter )
only this dont work with showing icons (put in ImgBurn.script + "Do not refresh shortcuts on ISO boot" enabled + autolocalisation enabled for tr)
here is a test script: http://lancelot.winbuilder.net/5F/ImgBurn_TEST.rar

***Info_X64: Gather files
Script developers, Avoid using "gather files" as script option, when hostOS is x64 (or vista) gathering files may result in gathering wrong files. (like gathering a .sys file may cause trouble)
If you have to use "gather files" as an option:
--Put a check routine to check hostos before gathering files (Example: Acronis-DiskDirector10.script)
--Gather files to a folder under %GlobalTemplates%\xxx....xxxx\ so user can gather files with a hostosxp32 computer and copy files to his/her hostos.

***Info_X64: ProgramFiles - programfiles
Script developers notes:
(Old issue report is moved to post #3 as main reason and solution found by fxscrpt (Thanks a lot) at post 647.)
For compatibility, dont use ProgramFiles in script, use programfiles,
Also dont use CommonProgramFiles in script, use commonprogramfiles
thumbdown.gif Not Compatible with x64hostos, only works right with x86hostos
thumbup.gif Compatible with x64hostos and x86hostos:
in contrast
shows %ProgramFiles% on x64
IniWrite,"%TargetDir%\%WorkDir%\CD-Opera\profile\Opera6.ini","User Prefs","Toolbar Configuration","%ProgramFiles%\CD-Opera\profile\toolbar\%ToolbarStyle_ScrollBox%.ini"
writes %ProgramFiles% to ini
probably this commands will be writing ProgramFiles(x86) in future which will be the right change with an unwanted result by hostosx64 user.
so better to use %programfiles% in scripts

this helps a lot smile.gif
%ProcessorType% ('386', '486', '586', '2200', '8664')
'2200' is the Intel 64 bit, '8664' that one of AMD
%Wow64% (True, False)
True when the 32 bit WinBuilder app runs on a 64 bit host OS
Points tho the system directory when a 32 bit app is brocessed by 64 bit OS
(thanks fxscrpt)
---Here is a min list:
The Variables
The commands
ps: death link new variables are introduced by peter,

**PeterPSC comment about xp64 from here
QUOTE (psc @ Nov 18 2008, 09:47 PM) *

Suggestion to all x64 users:
  • Offer your PC at ebay.
    I'm sure you'll get a good price, because there are enough fools thinking that they need it.
  • Buy a good old x32 at ebay.
    I'm sure you'll get it for good price, because there are enough fools thinking that they do not need it any more.

I would like to help and take your issue into the debugger.
But I only have x86-32. And just to buy 64 for 'playground' is too expensive for me.

Maybe I can give some help, if you 'eccessevely' explain the environment (no links please! cheers.gif )


Lancelot comment as an answer for Peter's comment: I am a happy x64 user. Maybe i am happy because i am a fool, but still i am happy.

An after a while rolleyes.gif here

QUOTE (psc @ Dec 9 2008, 04:53 PM) *
After a long time, I realized that I did not understand the real sence of your question:

In case of Wow64:

<shortcut request> -> BuildModel -> Shortcut : OK
<shortcut request> -> API -> BuildModel -> Shortcut : NOK

Current opinion: wodoo.gif

Let's see
I today ordered a 64 bit PC.
Maybe that helps (not the order itself, but using the PC after delivery)

Peter cheers.gif

***Info to remember

new cdimage parameters sometimes gives this: http://img60.imageshack.us/img60/2129/snap2nu0.png , nothing to worry, all files are in its place, just took picture and share here to document as command windows closes fastly.

***Info-Issues about OleSupport
ps: This issue is well known by masters, as this feature works mostly nice, it is kept (and i agree that) as an optional feature.
1) look post 344
devmgr.dll is not registered in PE (SP2 not visible, because pre-registered, SP3 not registered)
devmgr.dll is unregistered on my host pc. (my computer > manage > system > no device manager)
(run regsvr32 devmgr.dll on host to repair)
2) 'Stray registry entry' http://www.boot-land.net/forums/index.php?...ost&p=45737
getting the following registry entry created on my local host machine when building LiveXP: 'HKCU\WB-Temp\System\CurrentControlSet\Control\Windows\ShellErrorMode'.
3) for me with 2k3x64 , i have an experimental IE6 script, which works after registring dll, but dont work with oleout feature (all same order)
a) one should remember the already known issue about olesupport.script that is well explained by medevil at post 299
cool.gif and an Explanation post 16 of Peter from 'Stray registry entry' topic

***Info FBWF
Using fbwf enable, dera and i have different results. With fbwf enabled with 128mb, for a single file: dera can copy up to ~80mb, i can copy up to ~134mb
for more info: post 398,post 399,post 403,post 409,post 410
introduce a /minint trick and with previous posts (post 416) subject continues from post 491 (with dera's 80m limit) post 493 494 495 496 197 and at post 498 fxsrpt put a new script than continues 499 500 501 504 506

***Info Winbuilder variables
* Survey_wb_vars_20090108.pdf (Thanks to Maine Coon post 15xxx
* Galapo suggestion: project variables, defining for cross-project portability of scripts

***Why Exit dont work
Simple: you forgot a unhive in a script smile.gif
Basic: WinBuilder after the Exit continues until all hives are closed.
Advice: Use exit after you unhive and dont forget unhive on other scripts
Example: http://www.boot-land.net/forums/index.php?showtopic=7907

***Why i get this error
"This archive was built with a different version of ZLBArchive (v-2094635132) Extract File, %ScriptFile%, %AFolder%, %Archive%, %Target%"
Simple: redownload the file smile.gif
Reason: There should be something like
0=N3q8ryccAAMIsu ...
75=ai7EwzeVf4L ...
No other lines, no missing line between 0 and 75. If there is something else error occurs.
Reference: info from psc on this topic

Winbuilder.exe bugies i noticed

**winbuilder 075b5K
when code writing forgotten Begin
cause interface not working anymore (by adding spaces)
also adds spaces to sections too
i like adding spaces between begin-end
maybe to prevent use to be mistaken (fixing takes time)
-a warning saying (Begin section not closed)
-only begin-end inside the specific section, not outside

**IssueX64 Winbuilder.exe
clicking pictures on gui
Fixed with using cmd BUT
--Here is a test on x64hostos
Click on picture on gui of a script
you will see mspaint.exe opening the picture
check from taskmanager, you will see "mspaint.exe * 32"
which means C:\Windows\SysWOW64\mspaint.exe opened the picture,
not C:\Windows\System32\mspaint.exe
Should be fixed more properly with using System,FILEREDIRECT,OFF - cmd - System,FILEREDIRECT,ON in case in future someone uses x64 viewer.

**Winbuilder.exe boot-inf support bugies-missing
i got bored about this subject, idea is making inf compatible to both winbuilder and pebuilder. But sadly i cant trust Peter saying one day "upppps, i forget nodelete function of ; lines with .inf files" which is very essential for .inf files, people familiar with .inf files will understand my feelings. Instead i only make simple .inf files with no need of ; lines for that purpose (no problem with using // in some sections of .inf files).
Left issues:
-- winbuilder.exe MUST NOT delete ; lines of .inf files (probably solved now)
-- winbuilder.exe MUST NOT delete empty lines of .inf files
-- some shortcut issues reported before
-- there should be an option for shortcut creation (maybe yes maybe no, if no i need to have ability to delete folder if not exists)
-- gui dont work as it suppose to be ( post 40 )
-- i still insist to have winbuilder=0 at [pebuilder] section to disable winbuilder.exe to read .inf file which will make life easier. Reason is, i know convert complex .inf files to .script and i make 2 packages to distrubute.

QUOTE (psc @ Oct 18 2008, 10:42 PM) *
You should not be surprised. I'm ALWAYS interested in issues improving WinBuilder.
But sometimes I need a chair.gif

And if you (usually you do so) write something like 'just an idea' or 'not so important': Due to the amount of 'important' things I have to do here, I very fast will forget your post.

In the future: Do not go 'back' and if you think that something is important, tell us!
And, if like in the above sample, your post is decreased in my mind to 'nothing', increase it to 'important' again by a new post!
I'm not Mister God and can fail!

Peter thumbup.gif

Original post from here:

ps: Following post #3 and post #5 is to look or to remember solved issues.
(seperate posts (#3 and #5) due to forum quote rule: "You have posted more than the allowed number of quoted blocks of text" )


+Quote Post
post Aug 11 2008, 10:02 AM
Post #2
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


Thanks Lancelot for your tests and report!

I think I'll add some things to the tweaks script the next day or two.

A few comments:

HoJoPE script should copy C_1252.NL_ if it is needed by the system.

OLETHK32.DL_ should be copied by the nero script if that program depends on it.

notepad.script should be fixed so that opening of files works (it's annoyed me too, but I haven't gotten around to fixing yet).


Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Aug 11 2008, 12:08 PM
Post #3
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


following quotes are connected to post #1 of the topic:

*****Reminders of some old/solved issues:XP 64 Temporary Fixes
***IssueX64: minor bugy - 'Explorer shell TWEAKS and SETTINGS.script'
Reason: http://img360.imageshack.us/img360/8782/snap2ff6.png
Temporary solution made:

***IssueX64: "Do not refresh shortcuts on ISO boot" checked on --> no icons loaded on bootup
(somehow related to ***IssueX64 autolocalization script issue)
dera foud solution at post 906
ImgBurn.script using these lines fixes

***IssueX64 autolocalization script ( chair.gif Peter's script ) - Solution found which should be prepared manually, written at the end:
autolocalization script gives errors when host is x64 (maybe it is x64 fault, maybe not as peter says, maybe reason is script or maybe reason is i use 'winbuilder 075 beta 4' or maybe reason is winbuilder 074) (also tested with wb075b5)
for more info look post 256 to post 266
Enableing autolocalization dont give error in log but shortcut icons on desktop dont load and font problem with browser (opera or ie) when i go to some turkish websites.
detailed report is at post 245
++With new autolocalization script no errors on log but problem persists
++disableing autolocalization script fixes font issue with opera, but font issue continues when using IE (and probably rereported when a native language used in elsewhere)
++this issue is not fixed by adding C_932.NLS
++Maybe related to fxscrpt topic
Manual solution:
By dera's advice (post 246) i created a script for myself (i use xpsp2eng as source, turkish keyboard) by taking regs from a xpsp2x86 eng OS which is configured to use TR. Here it is (ONLY WHEN ENGLISH SOURCE USED to have TURKISH FONTS enabled): http://lancelot.winbuilder.net/5F_scriptsl...Eng-Font_TR.rar
Masters decide for more permenant solution rolleyes.gif
++copying only c_1254.nls and adding registry only for c_1254.nls solves the problem of no icon of bootup when "Do not refresh shortcuts on ISO boot" checked off. (post 904)

*****Rejected Subjects
DisplayProperties.Script at screensaver startup section, can we have "none" option
post 361
also following posts leading to Rejection of this Suggestion

***Issue: !WBVerify.Script - Dramastic have a idea
--->'Dramastic' date='Oct 24 2008, 07:19 PM' post='48081']
Please consider updating this to continue to run the verify script after launching the notepad program to display the errors found. Otherwise you have to memorize all the errors before you go fix them, or have to launch another WinBuilder window to make the corrections or copy paste elsewhere etc..
--->'psc' date='Oct 25 2008, 02:42 PM'
Show the log in notepad, appears at the very end of the verify script.
When I wrote the script I decided to stop processing until notepad is exited.
If not, the build woulde be continued, inspite there are facts which prohibit a successful build.
You do not have to remember 'all' the errors (usually only one): Verify.log is still available after build at %BaseDir%\Temp\<project>.
(If there has been no issue, Verify.log is not generaded)
It is deleted when starting the next verify.

*****Reminders of some old/solved issues:

%ramdrv%=B: question
%ramdrv%=B: gone with new 4 - BuildModel.Script and not exist in tempe, any plan to get it back?
look post #140
look post #148 for more detailed question, and look post #149 for answer from peter

x64 compatilibty issue 1
i only realize when using bulkrename script right click feature. look here for more info
@ ALL: NEVER USE #$pProgramFiles#$p in registry operations, use %PE_Programs%
Lool Post #153 and following posts for more info
As written in post #155 fixes relevant to this subject will be made for Acronis-DiskDirector10.script and CD-Opera.script too.
although you shouldnt use #$pProgramFiles#$p in registry operations thumbdown.gif
you can use #$pProgramFiles#$p in creating shortcut thumbsup.gif

Peter take this option out of "4 - BuildModel.Script" and told it will be in a seperate script. look post for more info
***Noticed thing (no issue noticed by me because of that):
in "4 - BuildModel.Script",
in changing source from 2k3 to xp (vice-versa), or xpsp3-xpsp2 or 2k3sp2-sp1 or source language.......
wont it be better to change line
i dont know exactly how convertion takes place and i dont have an issue about this, just reminding by obeying common sense.

Fix made to HivesFactory Version 46 to supress this warning. look post for more info
just info in case you have this warning:
unnecessary warning from "3 - hivesFactory.Script" that happens time to time
(i dont know when it happens and when not)
(when source is xpsp2 enu, 2k3 enu, xpsp2 tr, 2k3 tr)
RegDelete - Failed to delete registry key in: [HKLM\WB-Software\Microsoft\Active Setup\Installed Components],{4b218e3e-bc98-4770-93d3-2731b9329278}
This Warning means:
"3 - hivesFactory.Script" want to delete reg key of Internet Explorer Windows Marketplace, but as reg key is not there it is not deleted.
So dont worry with this warning smile.gif.
ps for regular users: look warning description from Peter (psc) if you have a misunderstand meaning of warning with winbuilder.

***Issue (solution found, will be deleted in near future when added to project):
LiveXP Search option / Find Target issue:
Solution: disable "setting file manager to explorer view" in "Explorer shell TWEAKS and SETTINGS.script", "setting file manager to explorer view" will be fixed in future so i will remove this issue :>.
for more info, look these:
suspect: 7 - OLESupport.Script
look dera's post 80
Also a note, Find Target works with galapo that opens the folder but dont select file (look post)
issue solved with some sources
now continues from here
*sub issue with "Explorer shell TWEAKS and SETTINGS.script", look post #142 #143 #144

***Issue: (very simple, not essential)
"Quick Launch shortcut to Windows Explorer" bugy
1st i do this setting with winbuilder gui
Basic--->Shells----------->Explorer-------------------->Quick Launch shortcut to Windows Explorer==>YES
when i click "Clean Temporary Files", and start build i got 2 errors
AddVariables - File [%ActiveShell%] was not found!
Failed to find section [Add-Shortcut] in file: [%ActiveShell%]
(under [%BaseDir%\Projects\LiveXP\Basic\Shells\Explorer.Script] section,
in subsection [%BaseDir%\Projects\LiveXP\Basic\Build\4 - buildModel.Script])
rerunning script solves the problem eventually,
also a script can be added to another stage of build, i wait galapo decide what to do.
Here is the log file:
Solution (for now):
Don't use "... shortcut to Windows Explorer" options in Explorer.script
or if you use, build twice

Some utilities dont like uppercase, like Firefox3,
CreateISO needs an additional feauture i guess
Read this post (and relevant previous posts) for additional info

***issue (minnnnnor, only cosmetic):
TAHOMABD font issue, makes desktop startmenu etc. bold.
look post 182 for more info and following posts.
Fix made inside Essentialfonts.script so arial font is used in apperance now, see dera's post 190 for fix http://www.boot-land.net/forums/index.php?...ost&p=43069

***issue (minnnor):
"verify project" dont give warning when temppe disabled,
solution: Don't disable temppe. smile.gif
look post #136 & look post #140

Above issues solved with first essential fonts script (v7) and finally with more centered way hojope script (wb075b5 needed), thanks a lot to fxscrpt:
***Issue (Very Minor)
Izarc have a very minor right click issue, i reported it here
Tahamo bold issue already fixed for me with EsentlFonts.script
there are some findings that can be useful so maybe making a fix with hojope (or maybe not) can solve Tahamo bold issue with a more centered way.
Peter decide what to do, i put a notice to 1st post, here is the topic page to get more detailed info
Also fxscrpt wrote in this topic:
"if tahoma font is not installed all seems ok , because arial is used.
if tahoma is installed (eg by EsentlFonts.script) all seems ok, because default settings of using tahoma
are overriden by EsentlFonts.script to use arial. i dont know whats wrong with EsentlFonts.script, but
running [Process-reg] in this script causes on my build a problem (Process Explorer does not start)"
processs explorer starts in my builds with my livexp, i demended log file but as hojope discussion is more essential i couldn reproduce, just putting one more notice in case.
***Issue (Minor) (Reason found)
OverDisk script look post 221
unreproducable by galapo but i never able to OverDisk work at my livexp. Probably reason is sth about using 2k3x64 as OS, one day i will find out the reason of this. (similar things happened before, i call this de ja vu now which means again 2k3x64 OS problem without knowing the reason)
**Solution found (by luck and dera):
Reason is my not enableing autolocalization script because it gives errors when i enable it (maybe it is x64 fault, maybe not as peter says, maybe reason is script or maybe reason is i use 'winbuilder 075 beta 4' or maybe reason is winbuilder 074), with disabled autolocalization OverDisk dont work.

***Issue (Solution found fix is waiting to be made)
localeAdditions.Script under livexp dont have support for hungarian to add arialbd.ttf (and also c_1252.nls)
for hungarian
Issue was resulted here with Peter's confirmation

'5 - TempPE.script' suggestion, post 225 of dera
I think it would be good to put a warning that the '5 - TempPE.script' not compatible with WB074
(at least now seems to me it is not compatible but maybe I am wrong)

may be unneccasary becouse new hojope needs wb075

DisplayProperties.Script update to v8 solves new hojope crash problem

***Suggestion for the mmc.script from fxscrpt
look post 313

Internet explorer 6 can be on livexp too for people who like it, but i dont know how, ultrabootwin cd who use pebuilder have internet explorer, so why not live xp too. I dont have any exciment to put ie to livexp, advantages may be: the language of ie will be the language of source automatically ; it comes from source so .script file will be small ; and everybody knows how to use ie, i never use ff and i know people that never use opera (and safari, and.....)etc.
dera prepared a IE6 script, which must be used with xpe_crypto.script

***Suggestion for mmc.Script from fxscrpt
please add
Expand,"%source_win%\dmocx.dl_","%target_sys%" to [InstallMMCCore] or to [InstallDeviceManagement]
(no devices in device manager , if disk management is unselected in mmc.script.)

localeAdditions.Script need to be updated for hungarian support, script already in nativeex

new wimpack.script cause vbverify
look post 343

***Issue ( post 348 )
in DisplayProperties.Script checking the option: Show"Colormanagement"Tab
after build
i open explorer and click "search" , than livexp crashed

***Issue (Minor) post 343
FixShellWinlogon.Script cause a minor thing, would be fixed when combined with misc settings in future i guess, just written here to remind.

***Suggestion for DisplayProperties.Script from dera
also a reg adding
(reason asked at post 342 answered at post 346 with very detailed explanation)

***Suggestion for OLESupport.Script from dera
look post 325
Problem about search box is solved but it is sth to remember smile.gif

***Issue (Minor)
create iso script needs a warning for fbwf that fbwflib.dll and fbwf.sys must be version 2.0.965.0
maybe script can check .dll and .sys files (i dont know if winbuilder do that or not)
or highly probably a text warning will be enough on gui of create iso script.
An issue happened when a user tried to use another version of fbwflib.dll and fbwf.sys which cause bad things reported in boot-land in another topic.
feature added to createiso by galapo, look post 345

thun's script is very nice for fbwf http://bartpe.boot-land.net/Projects/BartP.../FBWFldr.Script
it has percentage option (%10) and ready to use fbwf versions
Maybe it will be nice to use the abilities of this script in livexp project
I find a temporary way to use this script in Livexp but it will be better i guess to have this script with abilities of livexp nature.
- rename FBWFldr.Script to bFBWFldr_thuun.Script
- in script with notepad change Title=FBWF with Cache Threshold Adjust to Title=bFBWF_thuun with Cache Threshold Adjust
- in script with notepad change Level=5 to Level=7
- copy bFBWFldr_thuun.Script in \Projects\LiveXP\Finish\2 Create Image\ folder
- in gui of bFBWFldr_thuun.Script i disabled '"Set %temp% and %ramdrv% variables to "X:"'
- in gui of CreateISO.script i disabled "add file based write filter....."
- in gui of CreateISO.script i enabled "add win2k3sp1 setupldr.bin...." (this step may be irrelevant but i use this option and write here in case)
- in gui of CreateISO.script i enabled "use cdimage" with enabled "show cmd window" (this step may be irrelevant but i use this option and write here in case)
Suggestion accepted by galapo and a new createiso script is written by galapo, look post #384
New create iso script (will) have more features that prevent misusing and solves redistribution doubts. thumbup.gif

***Issue (solution found, will be deleted in future when added to project):
When there is no real network adapter, penetwork cant start, causing some utilities dont work (i know O&O defrag so far)
Highly probable solution will be a Virtual network adapter in case no real network adapter exist
For more info: Case started here ------> And continued here , issue solved with beta of penetwork will be solved permanently with final penetwork.

***Issue: (solution found, will be deleted in future when added to project, new penetwork script has this feature which will make this issue deleted when this feature is accesable using script.):
Random computer name support for network? (probably more than 1 people in lan using livexp)
here is report from esgaroth

***Issue (minor):
"local setting are not get properly when french source is used"
for more info look post 458 of galapo: In my opinion, it's an issue for either HoJoPE Hives Factory or localeAdditions to deal with. Peter will decide.
and previous posts about subject
fixed: look post 507 and previous posts about this subject

When using source 2k3sp2, dont use cdimage, use mkisof. Cdimage only works with source 2k3sp2english. (cdimage adviced and works with 2k3sp1 and xpsp2)
ps: 2k3sp2 source is not adviced for livexp, xpsp2 and 2k3sp1 are adviced. But for language trials 2k3sp2 is nice and optainable from MS site. The purpose of this info is to remind when such a trial made.
for detail look post 254 to post 264
fixed: look post 507 and previous posts about this subject

***Info (Reason Found)
When trying full livexp setup (after reading "Stray registry entry"), i got an error screen.
I couldnt reproduce it and as i immediately start trials i deleted the iso that happened,
after the first full build it never happened again,
just writing here to keep it in mind:
at startup before desktop shell comes this screen come:
after desktop shell runs this screen comes again.
If this issue happens again follow gapapo's post 443
1. Version of ExpEnvVar.exe
2. Contents of ExpEnvVar.txt
3. Contents of 'Microsoft\Windows\CurrentVersion\RunOnceEx\500' pre-boot (ie, mount software hive with Peter's RegEditWB in 'tools')
4. Apps starting in 'Startup' folder
Reason Found:
My misusage of ultraiso script - i used 2 ultra iso script with different versions that caused this error rolleyes.gif

***IssueX64 cd-opera.script:
(More approrite solution found and written in post 1 so i move this written things to post 3)
(solution found but as script writer MedEvil dont put x64 compatibility to script, till a new official winbuilder released, it will remain in list with modified cdopera script i made which solves issue with current official winbuilder, look cdopera page for more info)
*cd-opera.script .url association malfunction post #164
*cd-opera.script x64 compatibility (solution found will be deleted when fixes are made)
read post #153 for more info
Cd-Opera script development page Informed
++look post 566 for an interesting x64 compatibility
++look post 637 for fxscrpt confirmation
++look post 647 for fxscrpt reason explanation ('WOW64 imlementation detail')
Soution (for both):
i made some changes in Cd-Opera.script, x64 users can easly use it instead of existing Cd-Opera.script , also it wont have effect on x86 users too.
Here is to download

***IssueX64 Acronis-DiskDirector10.script: (solution found will be deleted when fixes are made)
Acronis-DiskDirector10.script x64 compatibility
read post #168 for more info
Acronis-DiskDirector10.script developer site informed
dont use "get files" option in acronis disk director 10 script if you are using x64 OS. Provide files by installing add on a x86 system (that is what i do).
Fixed by prohibiting getfiles option under x64hostos

***Issue: (Very Minor)
Shortcut cant be created as minimized
This line make a normal shortcut
This line make a maximized shortcut
This line make a normal shortcut, 4 means 'hide' but dont work
This line DONT make a minimized shortcut
api.script topic informed
look post #251 , post #253 , post #254 , post #258 , post #259 , post #260 , post #261
It seems Temp\livexp\Shortcuts\Notepad.shc written right and and file in modelram is with hex 02 at 3C (if it was 07 at 3C i dont think there will be a problem)
Something happen after this stages.
++At post 648 i wrote a code that works by fixing hex 3C, changing value to 07 (dont work in all cases becouse of bpatcher absent ability, just an example)
Solved: with api script 18, look here

****Issue: wb075b5u (and after) finds wrong script writing, info here
Scripts that should be fixed (found so far)
penetwork.script (FIXED - delete penetwork.script you have, and redownload)
IniWrite,"%ProjectInfo%","UPX-Switches","netplwiz.dll,"--best --compress-resources=0"
IniWrite,"%ProjectInfo%","UPX-Switches","netshell.dll,"--best --compress-resources=0"
IniWrite,"%ProjectInfo%","UPX-Switches","netplwiz.dll","--best --compress-resources=0"
IniWrite,"%ProjectInfo%","UPX-Switches","netshell.dll","--best --compress-resources=0"

smart_data_recovery.script (FIXED)
reg_add,0x1,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"DisplayName","Smart Partition"
reg_add,0x1,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"Version","2.0"
reg_add,0x4,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"Language",1
reg_add,0x4,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"ShowLastWindow1",0
reg_add,0x4,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"ShowLastWindow2",0
reg_add,0x4,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"ShowLastWindow3",0
reg_add,0x4,%reg%\Software\Smart PC Solutions\Smart Partition Recovery,"ShowLastWindow4",0
reg_add,0x1,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","DisplayName","Smart Partition"
reg_add,0x1,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","Version","2.0"
reg_add,0x4,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","Language",1
reg_add,0x4,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","ShowLastWindow1",0
reg_add,0x4,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","ShowLastWindow2",0
reg_add,0x4,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","ShowLastWindow3",0
reg_add,0x4,"%reg%\Software\Smart PC Solutions\Smart Partition Recovery","ShowLastWindow4",0

WinBuilder Critial Bug - (Shellexecute/Delete):
This issue is not fixed easly

Alexei report here Nov 3 2007, 12:29 PM
I (Lancelot) report here Jul 12 2008, 07:40 PM
After which lots of chairs around ( Lancelot Aug 7 2008 post , lots of bad answers, ex1 , Than also thanks to Gooroo to report this issue after which i believe i saved enough log files to show peter with a bug report but again bad posts from psc with again humilation here , and in the end with a new topic by psc (i guess i convinced him that there is a REAL bug at last) and resulting a fix found.

So one thing to remember, sometimes you should make a long fight if you really believe you are obsolutely right.

, at last the issue went to the history.

NEWS: ***added - ShellExecuteDelete command - wb075beta5 w
NEWS: *The following scripts and api (unpack) should be fixed to use ShellExecuteDelete command after an official release

Discussed and accepted before that this issue happens randomly (but more frequently with 2k3x64). As it is not reproducable here is a nice defination:
When an executable used by the script, sometimes executable remains in taskmanager causing deletion of the executable impossible in next line of the script which gives error in log.
There are some common incidents when this issue happens with solutions:
1) dont use unpack -y with an executable (if you are a script writer, use .7z in script not .exe).
2) If you want to 'extract'-'use'-'delete' and executable DON'T, instead use this order: 'if exist delete'-'extract'-'use'
Here are some logs for the proof: http://lancelot.winbuilder.net/5F_Log_Coll...cutable_Delete/
Here are some corrections made by me:

!WBVerify.Script (FIXED - ShellExecuteDelete)

change this line with

// FileDelete,"%VerExe%"

OODefrag10-api.Script (FIXED - api20 - ShellExecuteDelete)

change this line with

// lancelot cancel If,%pCheckBox3%,NotEqual,True,unpack,dfrgpro,DefragPro.exe,-y
If,%pCheckBox3%,NotEqual,True,ShellExecute,Hide,"%Tools%\7za.exe","x #$q%Target_Prog%\%ProgramFolder%\DefragPro.exe#$q -y -o#$q%Target_Prog%\%ProgramFolder%#$q"

ntfs_undelete.script (FIXED - api20 - ShellExecuteDelete)

change this line with

ShellExecute,Hide,"%Tools%\7za.exe","x #$q%Target_Prog%\%ProgramFolder%\ntfsundelete_sfx.exe#$q -y -o#$q%Target_Prog%\%ProgramFolder%#$q"

TDTools.script (FIXED - api20 - ShellExecuteDelete)

change this line with

ShellExecute,Hide,"%Tools%\7za.exe","x #$q%Target_Prog%\%ProgramFolder%\tdfiles.exe#$q -y -o#$q%Target_Prog%\%ProgramFolder%#$q"

partition_find_and_mount.script (FIXED - api20 - ShellExecuteDelete)

change this line with

ShellExecute,Hide,"%Tools%\7za.exe","x #$q%Target_Prog%\%ProgramFolder%\partition_find_and_mount_sfx.exe#$q -y -o#$q%Target_Prog%\%ProgramFolder%#$q"

asquare_free.script (FIXED - api20 - ShellExecuteDelete)

change this line with

ShellExecute,Hide,"%Tools%\7za.exe","x #$q%Target_Prog%\%ProgramFolder%\asquared_free.exe#$q -y -o#$q%Target_Prog%\%ProgramFolder%#$q"

Snapshot.script (FIXED)
move this line to the end of process section

%baseDir%\Projects\LiveXP\Finish\3 Emulation\VMWare.script (FIXED)

change this line with


Reminders continue in following post #5 due to the forum rule "You have posted more than the allowed number of quoted blocks of text"

original Post3

"HoJoPE script should copy C_1252.NL_ if it is needed by the system."
yep i learned from with 1st experience with tr support it is about HoJoPE script, nope it is not copied with tr source, yep copying it fixes all known problems.

try notepad association script i made, it fixes double click and .reg->edit problem

here are new things i remember:
one of acronis (probably true image) needs MSVCP71.DLL and MSVCR71.DLL to run properly.

i added ErdRoot.exe (which was in sherpya's erd2003 xpe plugin if i remember right) and put shortcut for it in case someone needs to set enviromental variables of target_root (regexpander use this env variable too if i remember right, but it finds windows folder itsself and do automatically and set the env variables, but when regexpander finds more than one windows it asks for which to use). ErdRoot is very mini file smile.gif.

ps: just a note for web admin: hehe now wide screen problem with codebox smile.gif, there was no wide screen problem when only code used smile.gif maybe reporting this is good too.

edit: extra_setting_Lancelot had a minor bug and fixed now

+Quote Post
post Aug 11 2008, 12:51 PM
Post #4
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


QUOTE (Galapo @ Aug 11 2008, 11:02 AM) *
HoJoPE script should copy C_1252.NL_ if it is needed by the system.

I already some days ago wanted to do so.
In NONE of the Turkish setup HIVE???.inf and INTL.inf is any hint for C_1252.nls frusty.gif
I think it is an issue of several software producers residing in the US and thinking that nowhere on the world are people NOT having the US 1252.

I suggest to include it in Copy&Expand.
More logically but also more work to implement would be to include this in the app scripts using it.


Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Aug 11 2008, 01:09 PM
Post #5
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


*****Reminders of some old/solved issues: (following from post 3)
***IssueX64 VMWarePlayerWorkstation.Script
Minor have no effect, will be solved with new build-time dll registration method
for more info: post 718 , post 721 , post 722
Solution: "Use Dll init at boot time" option added to the script.

Windows Installer script?
*Solved, now we have a downloadable ready script for that in livexp project

***Issue: (Tiny Miny - Cosmetic)
Where is the line http://img376.imageshack.us/img376/7559/12341234xw2.png smile.gif
(tested with livexp and NativeEx_barebone)
Solution: Basic--->Tweaks--->Explorer Shell - Tweaks and Settings ---->Disable "Display simple folder view in Explorer's folder list

****Issue: FixShellWinlogon.Script - 24-hour limit in LiveXP
in some machines enableing "24h-limit" cause BSOD, reported that dera 'b' machine and funtik machine have BSOD.
details are in 24-hour limit in LiveXP topic.
Solution: new fxshellwinlogon.script and miscsettings.script are now on livexp, they have 10 seconds delay to apply 24h limit

***Issue: !WBVerify.Script ( chair.gif Peter's script )
delete .\Temp\LiveXP\ and click Help button on gui of !WBVerify.Script, wb cant extract file because there is not a folder, so gives error for not finding file.
This section
should be this.

***** firewall pauses Download error VEEERRRYY important,
vista firewall giving permission to winbuilder.exe downloading HPUSBF.exe results with hanging winbuilder.exe (yes, link is working), user must close winbuilder.exe with taskmanager, but there is a partial HPUSBF.exe (96kb) which causes failure in bootsdi step.

this is defcon 2 i guess

i found this when i was testing wb with vista, this happens with wb075b5A , wb075b5B (but better) wb075b5H. winbuilder.exe errors slightly different through versions, but there is always error.

Better to make a movie with wb075b5H,

shortly with words, with wb075b5H download dont continue after giving permission to firewall BUT there is xxx.exe in tools folder causing script malfunction.

longly description of movie: (vista32bit, uac disabled):
1) i show no HPUSBF.exe in tools folder,
2) source code of test script (link working)
3) at 35sec of movie, i show no download in progress with dumeter dl indicator
4) at 50sec of movie, i show there is HPUSBF.exe with 0kb in tools folder
5) at 1:02sec of movie, i show there is HPUSBF file extension is .exe (for confirmation) + 0bytes
6) at 1:20, i show stop not working
7) at 1:27, i show clicking X not working
8) at 1:42, at last i decide to close with taskmanager

Well in second run, winbuilder.exe wont have a firewall trouble as permission given, but still there is HPUSBF.exe in tools folder which will cause script malfunction.

And here is the movie:
http://lancelot.winbuilder.net/5F/winbuild...irewall_AVI.rar (2.25mb)
Probably reason is vista32sp0, this event didnt happen again with vista32sp1

****Issue: VistaSP1 behaviour with vdk usage:
vdk only works with first boot of vista
post 18 briefly descibes the problem
psot 20 describes probable solution
Temporary solution: vistasp1 users, use bootsdi w/o wimpack after freshly booting vista
*Solutin found and added to bootsdi and wimpack scripts: vdk usage changed to temporary unique folder which solves problem permanently

****Issue: Exit, dont work in LiveXP: post 950, 951, 952
A script with this
Exit,"exit message"
shouldnt end with this
Solution: post 953 reason found by Peter:
After forgetting unloading hive, when the Exit command occurs, WinBuilder continues reading and processing important lines, until all hives are closed.
BTW: Logically the hive is closed anywhen in a RegHIveLoad and RegHiveUnload pair, and no mounted hive is left in the registry.
But for WinBuilder which only counts, there is still one hive open.
** "Explorer Tweaks and Settings" and updated to fix the problem.

***Issue: Winbuilder.exe - Shellexecute - fxscrpt post 942 , 943, 944, 945, 946, 947, 948, 949
QUOTE (fxscrpt @ Dec 24 2008, 05:29 PM) *
Consider the following scenario:
you have mounted a virtual HDD image (Imdisk).
Lets say, the Drive is Y:.
Open command prompt and type imdisk -D -m Y: to unmount.
(Duration : 2 sec)
(Duration : 35 sec)

Solution: post 962 , wb075b5J solved.

*x*x*x*MEGA Important x64 Issue-----winbuilder.exe - List index out of bounds
everthing works with wb075beta5w, but trials with wb075beta5z and wb075beta5A cause "List index out of bounds" error.
details are in post 842
Solved without knowing how after wb075b5B

** very Minor: (but also very disturbing)
There is folder-view missing for a while after wb075b5B
Here is a movie with wb075b5I

at 00:06 second, when i click Diag on left, there is still Devcon on gui
at 00:12 second, when i click Apps\Internet on left, there is still Devcon on gui

i hope it is understandable and clear and considered as 'reported carelfully'
peter says fixed, probably after wb075b5I (this note will be deleted when i get newer version) - fixed with wb075b5J

**ToDO: ImgBurn
Idea 1) ImgBurn, why not adding a simple question box? , Do you want to burn cd or not smile.gif
Idea 2) Maybe on script.project a checkbox 'i want to burn iso to cd'
TODO: ImgBurn is also the answer for Special subtopic: Should ImgBurn came up in the end or not
Peter's comment:
As far as I know, EVERY Expert, Standard, or Dummy user is able to select a script if he/she wants to include it into the build.
BTW: For the above reason in natoveEx_barebone_075 I just moved the 'Burn' to the Tools folder (besides e.g. RegEdit) and made it unselectable.
Amalux comment:
I like the option to burn a CD at the end of the build (just an option, no reason to waste a CD or time); believe it or not, newbies might not know how to burn an ISO to CD and this gives them an easy option to do so. If the script is unselected by default, this option is lost and may cause more troubles for newbies. Unless something has changed, ImgBurn should NOT automatically burn a CD if one is in the drive or even give an 'error'; just open and wait for user input. Simply closing ImgBurn moves past this CD burn option without issue, no?

Solution: I put together the demanded things from this topic in my way and explained on post 26, i hope others like

*********Discussion (will be made later after galapo joins back)
Ingredient of recommended Livexp, how should it be smile.gif
Peter's comment:
In my opinion, the 'recommended' download maybe shoud have the scripts it currently has.

But it should have much less SELECTED scripts!
In the very first trial, running into an emulator, MassStorage drivers, AntiVir scripts etc. are really not necessary.
They can be added by the user if he wants to burn a real CD or to build an USB stick.

solution: Galapo came and wrote the things that are obvious

**TODO: cdob's idea at post 988
cdob's comment: I like to uppercase required files only and changed CreateISO.script
Check to see if ff3 works with that code
//for uni- and multiprocessor script +
//for uni- and multiprocessor script -
echo,"Creating ISO: [%isofile%] Folder size: %sizeFolder%"
//cdob: uppercase textmode boot files
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q /d #$q%targetdir%\i386\#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q /d #$q%targetdir%\i386\system32\#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q /d #$q%targetdir%\i386\system32\drivers\#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\BOOT#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\win51*#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\bootfont.bin#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\*.bin#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\*.si?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\*.in?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\ntdetect.com#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\spcmdcon.sy*#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\*.in?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\ntoskr*.ex?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\ntkrnlmp.ex?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\kdcom.dl?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\bootvid.dl?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\setupreg.hi?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\*.fo?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\*.nl?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\hal*.dl?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\SYSTEM32\drivers\*.sy?#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q #$q%targetdir%\i386\system32\win*.sif#$q"
ShellExecute,Hide,"%Tools%\filecase.exe","/u /h /q /d /s #$q%targetdir%\i386\system32\$OEM$#$q"
echo,"ISO build size is %sizeISO%"

If,%pCheckBox4%,Equal,True,Set,%opt%," -o"
// CDIMAGE.EXE -lLiveXP -h -j1 -m -bD:\winbuilder_LiveXP\Target\LiveXP\bootsect.bin D:\winbuilder_LiveXP\Target\LiveXP "D:\winbuilder_LiveXP\ISO\LiveXPCdimage.iso"
If,%pCheckBox1%,Equal,true,ShellExecute,Open,"%Tools%\cdimage.exe","-l#$q%pTextBox1%#$q %pScrollBox2%%opt% -b#$q%targetdir%\%BootSect%#$q #$q%targetdir%#$q #$q%IsoFile%#$q"
If,%pCheckBox1%,NotEqual,true,ShellExecute,Hide,"%Tools%\cdimage.exe","-l#$q%pTextBox1%#$q -h -j1 -m -b#$q%targetdir%\%BootSect%#$q #$q%targetdir%#$q #$q%IsoFile%#$q"

If,%pCheckBox1%,NotEqual,true,ShellExecute,Hide,#$q%Tools%\mkisofs.exe#$q,"-iso-level 4#$s-volid #$q%pTextBox1%#$q -b %BootSect% -no-emul-boot -boot-load-size 4 -hide bootsect.bin -hide boot.catalog#$s-duplicates-once -o #$q%IsoFile%#$q #$q%targetdir%#$q"
If,%pCheckBox1%,Equal,true,ShellExecute,Open,#$q%Tools%\mkisofs.exe#$q,"-iso-level 4#$s -volid #$q%pTextBox1%#$q -b %BootSect% -no-emul-boot -boot-load-size 4 -hide bootsect.bin -hide boot.catalog#$s-duplicates-once -o #$q%IsoFile%#$q #$q%targetdir%#$q"
nicely working with ff3 and added to create iso

****Issue: 7 - OLESupport.Script ( chair.gif Peter's script )
Problem happened when vmCrypro.script and VMWarePlayer.Script selected
change this line with
*Fixed smile.gif

**TODO: script.project
-For Peter's concerns about build time solution Minimum
Maybe Minimum button sayin "Try it first, if you like make a real build with Pressing Big Blue Play Button" maybe nice.
Check Peter's suggestion at post #46
QUOTE (psc @ Jan 4 2009, 12:35 PM) *
Long time ago I already suggested a 'precompiled list' of scripts.
That is not only simpler, that is also much faster.

But nobody liked the idea and therefore I did not continue.

If you are interested, download nativeEx_PuzzleXP from the nativeEx server and have a look how it works.

Maybe minimum for new users on winbuilder webpage
solution: we have minimum button on script.project now

**TODO: Sigmatel audio driver
With info's given at post 985 Maybe a script to make enable sigmatel drivers to build more easly
solution: now dipe fully supports sigmatel

****Issue: winbuilder.exe - !WBVerify.Script (Unreproducable)
Galapo try to choose winbuilder.exe versions that dont have this issue, but Peter couldnt figure out the reason so i keep this error report in post1.
*Galapo have this issue with wb075b6 (and with some previous versions) + !WBVerify.Script v43
*Galapo dont have this issue with wb075b5T + !WBVerify.Script v43
++amalux have this issue too, explained here
Galapo and some others like JonF (JonF solved with a dejavu) (not me and not psc Peter) get this error with !WBVerify.Script,
temporary solution: disable !WBVerify.Script (Basic--->!WBManager-->Verify Project)
It is what i call "dejavu issue", which means it disappears when you change sth without knowing what, and happens again in a different script with same error which makes you feel "himmm, i saw that before, but what was the fix! (dejavu)"
Generated by psc program 'WBVerify' version 2.2.0
Date: 2008-Nov-05 08:37:49


Problem with line: Call "WBVersion" (Build Model,075); (If {%Build Model:Main.Selected%} & {%script.project:Main.WBVersion%<075} Then "Build Model needs at least version 075 of WinBuilder";)
Problem with line: Call "WBVersion" (Copy and Expand files,071.03); (If {%Copy and Expand files:Main.Selected%} & {%script.project:Main.WBVersion%<071.03} Then "Copy and Expand files needs at least version 071.03 of WinBuilder";)
Problem with line: Call "WBVersion" (ImDisk,071.03); (If {%ImDisk:Main.Selected%} & {%script.project:Main.WBVersion%<071.03} Then "ImDisk needs at least version 071.03 of WinBuilder";)
Problem with line: Call "WBVersion" (Explorer,071.03); (If {%Explorer:Main.Selected%} & {%script.project:Main.WBVersion%<071.03} Then "Explorer needs at least version 071.03 of WinBuilder";)
*Fixed I dont know how:)
Fixed at last: http://www.boot-land.net/forums/index.php?...ic=6960&hl=

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute

which is read by any process during PE boot.

If the key is empty, (Hex(00 00)) nothing happens.

But when the key is missing, the 'any process' uses the default value
Autocheck autochk *

Billy the Door, you are the greatest!

Keep an eye on winbuilder versions since bugies sometimes repeat themselves, this is first reported as wb077rc1 bug "hex(7) values are 00 00 00 the value is not written on the reg" at post 1489, issue also reported here post 9

**winbuilder exe Suggestion (rejected) half accepted, now we can download new version with different extension and date smile.gif
Step back availability:
QUOTE (Lancelot @ Aug 7 2008, 09:34 AM) *
a suggestion for WinBuilder 075

i make my backups manually before downloading, to be able to turn back to previous version of script,

There maybe a "backup option" (or "save previous option") would be nice in download section,

as an example:

i have xpe-pnp-aio.script version 012,
now a new version of xpe-pnp-aio.script is available,
if there is a "save previous option" which is selected (not default smile.gif ),
before downloading winbuilder can make a backup of the script
so in the end in the folder there are these files.
.\Projects\LiveXP\Drivers\5 Other\xpe-pnp-aio.script
.\Projects\LiveXP\Drivers\5 Other\xpe-pnp-aio.script_Version=012.7z

not an essential thing, only a mini suggestion smile.gif

file name of backup may have a date of time backup taken which would help more to go back to previous stages, example: xpe-pnp-aio.script_Version=012_20080512.7z

Original Post 5
you are the master,
can you or galapo tell me the right syntax for
if source=tr
so it will be more easy to include sourcetr support, i am still a learning rookie smile.gif

a little cosmetics smile.gif
in ..\LiveXP\script.project
changing line
makes pTextLabel2 things readable smile.gif

ps: extra_setting_Lancelot had a minor bug and fixed now

+Quote Post
post Aug 11 2008, 01:17 PM
Post #6
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


QUOTE (Lancelot @ Aug 11 2008, 02:09 PM) *
you are the master,
can you or galapo tell me the right syntax for
if source=tr
so it will be more easy to include sourcetr support, i am still a learning rookie smile.gif

With nativeEx based projects like LiveXP, and with latest WinBuilder beta:
<first turkish special statement>
<second turkish special statement>
  <last turkish special statement>

With nativeEx based projects like LiveXP, and with older WinBuilder:

<first turkish special statement>
<second turkish special statement>
  <last turkish special statement>


Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Aug 11 2008, 04:12 PM
Post #7
Frequent Member   ******
Group: .script developer

  Joined: 8-May 08 From: Turkiye/Izmir

Posts: 3,520
Thank(s): 380


Thanks a lot Peter,
now with learning the usage of projectinfo, life is easier smile.gif


To prevent tr font problem with tr source selected, here are lines that works successfully (tested)
I have ideas in mind writing a script named "sourcefix.script" and in description "fixes issues when source selected other than English (enu)" , also in support list for now "Turkish Source Fixed" but it seems to me better to leave what to decide to you as you will now what to put where/how in livexp more than me.

<first turkish special statement>
<second turkish special statement>

Also with new winbuilder 075 beta j, now warning messages comes when regdelete try to deletes non existand key.
to prevent unnecessary warning i fix extra_setting script in 1st post

just to inform: also i think about doing similar personal adding for hivesFactory.Script , info is here: http://www.boot-land.net/forums/index.php?...ost&p=41802

3) Galapo there are 4 scripts that are incompatible with source2003 (i tested only with "2k3sp2 trials")
These are:

in process section of these scripts in first line i put
Echo, "This script works only when source is XP"
and in last line

which worked fine for me, so no need to worry about warnings when changing source now smile.gif

Question, for qemu when selecting xp as source,
one should select QemuNIC-W2k3.script + qEmuNIC_RTL8139.script
when using xp QemuNIC-W2k3.script only
when using 2k3 qEmuNIC_RTL8139.script only
ps: i know QemuNIC-W2k3.script has w2k3 name but it doesnt work with 2k3 sp source.


+Quote Post
post Aug 11 2008, 04:24 PM
Post #8
Guru   ******
Group: .script developer

  Joined: 14-July 06 From: Korschenbroich

Posts: 8,443
Thank(s): 441


@ Forum Administration:
I suggest to promote Lancelot to our second 'Bug Catcher' cheers.gif

@Lancelot, Galapo:
I want to make some additional suggestions and maybe also some contradicts to Lancelot's post.
But currently I'm in the middle of a 'partly redesign WinBuilder' and do not want to divide my concentration (This post is 'just written')

Please do not do some final things and wait for me until tomorrow.


Build the house starting with the basement rather than with the roof! But always have in mind how the roof should be made!

There are very rarely problems, in most cases there are issues.

There are never stupid questions, there can be only stupid answers.

+Quote Post
post Aug 12 2008, 01:30 AM
Post #9
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


QUOTE (psc @ Aug 11 2008, 10:51 PM) *
I suggest to include it in Copy&Expand.

I agree. If it is left up to individual scripts to copy, this can be rather hard to know unless the script developer tests outside of English environment.

I suggest to promote Lancelot to our second 'Bug Catcher'

I wholeheartedly endorse this suggestion!

I've uploaded what is hopefully a fixed version of notepad.script.


Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post
post Aug 12 2008, 01:55 AM
Post #10
Platinum Member   ******
Group: .script developer

  Joined: 16-July 06
Posts: 3,136
Thank(s): 256


QUOTE (Lancelot @ Aug 11 2008, 10:08 PM) *
here are new things i remember:
one of acronis (probably true image) needs MSVCP71.DLL and MSVCR71.DLL to run properly.

I just tested DD10 and TI Workstation 9.1 without those two files and both ran fine: partition resizing with DD10 and folder backup with TI. Perhaps there's another script you were thinking of?


Recommended steps to build LiveXP:
1) Download suitable WinBuilder.exe from here and run it;
2) Update through the Download Center by clicking the 'Download' button; and
3) Then build LiveXP by pressing the 'Play' button.
+Quote Post

184 Pages V   1 2 3 > » 
Reply to this topic
4 User(s) are reading this topic ()


  Topic Replies Topic Starter Views Last Action
No New Posts LiveXP shutdown process
4 Arjun 381 9th November 2009 - 01:43 AM
Last post by: TheHive
No new Topic has attachmentsLiveXP Troubleshooting
Various questions and answers
92 JohnBug 8,397 29th October 2009 - 02:25 PM
Last post by: amalux
No New Posts Topic has attachmentsLiveXP WB078 Slow Load
64.4Mb ISO Slowly loading....*VIDEO*
11 dsolomon 941 20th October 2009 - 06:56 PM
Last post by: psc
No New Posts LiveXP Adding Driver?
6 Furgy 696 13th October 2009 - 11:30 AM
Last post by: Lancelot
No new Topic has attachmentsLiveXP not detecting Raid Controller
39 pantner 2,329 7th October 2009 - 04:22 AM
Last post by: Galapo

Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum