Digg this topic Add to my del.icio.us Submit to SlashDot 16 Pages V   1 2 3 > »   
Reply to this topicStart new topic
> [project] New Make Script, Make a script quickly
pedrole15
post Oct 17 2006, 01:40 AM
Post #1


Advanced Member
***

Group: .script developer
Posts: 233
Joined: 18-August 06
Member No.: 183


France


Make Script Project:

New version 13 of MakeScript
Writen in AutoIt
----------------------------------------------------------------------
Attached Image


Pedro

my web page
Go to the top of the page
 
+Quote Post
edborg
post Oct 17 2006, 07:06 AM
Post #2


Advanced Member
***

Group: .script developer
Posts: 259
Joined: 14-July 06
Member No.: 4



Great improvement! (IMG:http://www.boot-land.net/forums/style_emoticons/default/thumbup.gif)
This is what I was waiting for (particularly encoding files).
I'm going to test it immediately, thanks (IMG:http://www.boot-land.net/forums/style_emoticons/default/smile.gif)
edborg
Go to the top of the page
 
+Quote Post
psc
post Oct 17 2006, 08:01 AM
Post #3


Guru
***

Group: .script developer
Posts: 3,152
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


I get an error when running the script:
Attached Image

I have directories with spaces in the name.

So at least one pair of #$q is missing in the script.

Peter
Go to the top of the page
 
+Quote Post
TheHive
post Oct 17 2006, 10:57 AM
Post #4


Advanced Member
***

Group: .script developer
Posts: 1,887
Joined: 14-July 06
Member No.: 5



Thanks for posting the Script with version number and Screenshots.
This should be a great Plugin. Thanks! (IMG:http://www.boot-land.net/forums/style_emoticons/default/thumbup.gif)
Go to the top of the page
 
+Quote Post
TheHive
post Oct 17 2006, 12:40 PM
Post #5


Advanced Member
***

Group: .script developer
Posts: 1,887
Joined: 14-July 06
Member No.: 5



When testing and build my first Script. I get this error.
(IMG:http://img201.imageshack.us/img201/6627/errorpp1.th.jpg)

Log
Attached File  log_Make_Script.htm ( 39.35K ) Number of downloads: 31
Go to the top of the page
 
+Quote Post
edborg
post Oct 17 2006, 01:01 PM
Post #6


Advanced Member
***

Group: .script developer
Posts: 259
Joined: 14-July 06
Member No.: 4



I get these errors:

#166 [Failed] INIRead - Failed to read value from: [%BaseDir%\Temp\Mkscript.txt] Section: [FolderName] Key: [1] to variable: [%FolderName%]
#168 [Failed] INIRead - Failed to read value from: [%BaseDir%\Temp\Mkscript.txt] Section: [SourceFolder] Key: [1] to variable: [%SourceFolder%]
#172 [Failed] Encode - Failed to encode files on: [%BaseDir%\Archive\Apps\IrfanView.script] Section:[%FolderName%] Files to encode: [%SourceFolder%\*.*]
#178 [Failed] INIRead - Failed to read value from: [%BaseDir%\Temp\Mkscript.txt] Section: [FolderName] Key: [1] to variable: [%FolderName%]
4 error(s) while processing.

and the files are not encoded (IMG:http://www.boot-land.net/forums/style_emoticons/default/sad.gif)
edborg
Attached File(s)
Attached File  log.html ( 36.02K ) Number of downloads: 27
 
Go to the top of the page
 
+Quote Post
psc
post Oct 17 2006, 02:18 PM
Post #7


Guru
***

Group: .script developer
Posts: 3,152
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


QUOTE (TheHive @ Oct 17 2006, 02:40 PM) *
When testing and build my first Script. I get this error.
(IMG:http://img201.imageshack.us/img201/6627/errorpp1.th.jpg)

Log
Attached File  log_Make_Script.htm ( 39.35K ) Number of downloads: 31


I think that this is also a 'Directory names with spaces' issue like i replied before.

In your error screen shoot 'Open' is assumed to be 'Open Builder'

Peter
Go to the top of the page
 
+Quote Post
psc
post Oct 17 2006, 02:21 PM
Post #8


Guru
***

Group: .script developer
Posts: 3,152
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


QUOTE (edborg @ Oct 17 2006, 03:01 PM) *
I get these errors:

#166 [Failed] INIRead - Failed to read value from: [%BaseDir%\Temp\Mkscript.txt] Section: [FolderName] Key: [1] to variable: [%FolderName%]
#168 [Failed] INIRead - Failed to read value from: [%BaseDir%\Temp\Mkscript.txt] Section: [SourceFolder] Key: [1] to variable: [%SourceFolder%]
#172 [Failed] Encode - Failed to encode files on: [%BaseDir%\Archive\Apps\IrfanView.script] Section:[%FolderName%] Files to encode: [%SourceFolder%\*.*]
#178 [Failed] INIRead - Failed to read value from: [%BaseDir%\Temp\Mkscript.txt] Section: [FolderName] Key: [1] to variable: [%FolderName%]
4 error(s) while processing.

and the files are not encoded (IMG:http://www.boot-land.net/forums/style_emoticons/default/sad.gif)
edborg


This is a WinBuilder bug.
It is fixed in the latest 052 beta3 version.

Peter
Go to the top of the page
 
+Quote Post
edborg
post Oct 17 2006, 03:02 PM
Post #9


Advanced Member
***

Group: .script developer
Posts: 259
Joined: 14-July 06
Member No.: 4



QUOTE (psc @ Oct 17 2006, 04:21 PM) *
This is a WinBuilder bug.
It is fixed in the latest 052 beta3 version.

Peter

Thanks for the link (IMG:http://www.boot-land.net/forums/style_emoticons/default/smile.gif) , but unfortunately same errors (IMG:http://www.boot-land.net/forums/style_emoticons/default/sad.gif)
edborg
Attached File(s)
Attached File  log.html ( 36.13K ) Number of downloads: 19
 
Go to the top of the page
 
+Quote Post
pedrole15
post Oct 17 2006, 03:05 PM
Post #10


Advanced Member
***

Group: .script developer
Posts: 233
Joined: 18-August 06
Member No.: 183


France


QUOTE (psc @ Oct 17 2006, 02:18 PM) *
I think that this is also a 'Directory names with spaces' issue like i replied before.

In your error screen shoot 'Open' is assumed to be 'Open Builder'

Peter

All work before I change the MksConvert.exe by the MksConvert.au3

Probleme is here :
ShellExecute,Open,"%AutoIt3%","%exeDir%\%au3% #$q%TMPscript%#$q #$q%MKscript%#$q"

Change to
ShellExecute,Open,"%AutoIt3%",#$q"%exeDir%\%au3%#$q #$q%TMPscript%#$q #$q%MKscript%#$q"

I have make change in the script reload it from first post
I think it work now
Go to the top of the page
 
+Quote Post

16 Pages V   1 2 3 > » 
Fast ReplyReply to this topicStart new topic

Members Who Viewed Topic Today ()

 

RSS Lo-Fi Version Time is now: 27th October 2007 - 11:15 AM

MKPortal ©2003-2006 mkportal.it