Digg this topic Add to my del.icio.us Submit to SlashDot  
Reply to this topicStart new topic
> [Bug] WinBuilder 072a RegRead HKLM fails, RegRead HKLM only works for admin user
booty#1
post Aug 27 2007, 09:20 AM
Post #1


Advanced Member
***

Group: .script developer
Posts: 182
Joined: 30-March 07
Member No.: 4,830


Germany


Hi Nuno,

I just tried to read an String via RegRead by a WinBuilder process that was executed only with user permissions and not administrative permissions.
I noticed that under that conditions WinBuilder fails to read values from HKLM even though the correspondent keys and values can be read by the used user account. (IMG:../forums/style_emoticons/default/confused1.gif)

booty#1
Go to the top of the page
 
+Quote Post
Nuno Brito
post Aug 27 2007, 12:51 PM
Post #2


Advanced Member
***

Group: .script developer
Posts: 4,153
Joined: 13-July 06
From: Azores
Member No.: 1


Portugal


Hi booty!

So far all testings in wb have been done under administrative level accounts to allow all possible registry operations also requiring UAC to be disabled under Vista.

Can you load registry hives under user permissions? (IMG:../forums/style_emoticons/default/huh.gif)

It is possible to bypass all security permissions on registry keys when you read them in raw mode - and I guess this is possible even under the guest account.

Still some research needed on this area - I'm mostly worried about loading and writing raw hives without resorting to any win32 api but reading data from raw reg keys is a fairly easy process, maybe it gets implemented on wb if I manage to read the raw reg data straight from the kernel memory soon enough and avoid using the physical hive files but I'm not sure when time will be available to get back on this part again and implement it in a stable fashion.

(IMG:../forums/style_emoticons/default/smile.gif)


btw: noticed your latest scripts - excellent work! (IMG:../forums/style_emoticons/default/thumbsup.gif)

Go to the top of the page
 
+Quote Post
booty#1
post Aug 28 2007, 06:44 PM
Post #3


Advanced Member
***

Group: .script developer
Posts: 182
Joined: 30-March 07
Member No.: 4,830


Germany


Well, this thread "drifted away a bit" so let's come back and pretend to be serious...

I accept that in 99.9% cases WinBuilder require administrative permissions anyway therefore I would not mind me if RegRead remains as it was - but while thinking about it I may be found another shortcoming which should be addressed by future WinBuilder versions:

Error handling. Sometimes it may be wise in a script to check if the last x commands were executed without error. From what I know WinBuilder has no command or variable for testing for errors of past commands.

My first intention was something like an internal error counter and a possibility for resetting this error counter.
A simple implementation would be a variable like %ErrorCounter% or something similar.

booty#1
Go to the top of the page
 
+Quote Post
psc
post Aug 28 2007, 06:56 PM
Post #4


Guru
***

Group: .script developer
Posts: 2,983
Joined: 14-July 06
From: Korschenbroich, Germany
Member No.: 3


Germany


(IMG:../forums/style_emoticons/default/thumbsup.gif)
I fully agree.

I would not post just the 'agree' if I wouldn't have any addition.

If you look at my FileByteExtract error support, it would be nice if the script could 'switch expected errors off', like the good old VB 'On Error'

BTW: I'm still having my "drifted away a bit" opinion, but with this, let's go to a different topic. (IMG:../forums/style_emoticons/default/hypocrite.gif)

Peter

EDIT by jaclaz:
"drifted away" is here now:
http://www.boot-land.net/forums/index.php?...c=2949&st=0




This post has been edited by jaclaz: Aug 29 2007, 04:55 PM
Go to the top of the page
 
+Quote Post
« Next Oldest · Support and Bug reporting · Next Newest »
 

Fast ReplyReply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts WinBuilder Caption
3 psc 75 10th October 2007 - 11:20 AM
Last post by: Nuno Brito
No New Posts Winbuilder Licensing
8 rt10k 241 4th October 2007 - 07:50 AM
Last post by: Alexei
No New Posts Topic has attachmentsBug "VistaPE boots into black screen" and how to fix it
VistaPE v008 bug caused by "wrong" NTFS permissions
5 booty#1 544 14th September 2007 - 07:09 AM
Last post by: booty#1
No New Posts Winbuilder and user account restrictions
13 psc 626 29th August 2007 - 05:11 PM
Last post by: smiley
No New Posts Winbuilder problems with UAC
4 booty#1 377 29th August 2007 - 04:33 PM
Last post by: smiley


 

Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum

- Lo-Fi Version Time is now: 12th October 2007 - 03:47 AM

MKPortal ©2003-2006 mkportal.it