Digg this topic Add to my del.icio.us Submit to SlashDot  
Reply to this topicStart new topic
> TFTPD32 with Cisco 6509, Access denied Error 32 Problem
Peter H
post Aug 17 2007, 01:46 PM
Post #1


Newbie
*

Group: Members
Posts: 2
Joined: 17-August 07
Member No.: 10,168


United Kingdom


Hi All

I have come across a problem using tftpd32 with our 6509 Cisco Core which I have seen mentioned elsewhere but haven't seen a fix.

Basically TFTPD32 is installed on a management machine for occasional collection of configs/images etc and works fine. Fine that is until we upgraded to 6509 core switches. Any attempt to copy from the 6509 to TFTPD32 gives a "Permission Denied" error on the Cisco Console and error 32 on TFTPD32.

I have prepared filtered capture files of the transfer and the same (working) transfer to Solar Winds TFTP Server... it appears the 6509 sends out two write requests at the start of the conversation - both identical (apart from the packet number). Solar Winds replies both times with an acknowlegment at block 0 whereas TFTPD32 replies to the second one that the file is busy and can't be opened, then fails.

I actually believe the error is cisco's as there's no reason to send two identical write requests in my view, however Solar Winds works so I suspect it's a feature of TFTP.

Is anyone aware of a fix or will this be one for a future update?

Go to the top of the page
 
+Quote Post
TopBrick
post Aug 17 2007, 10:13 PM
Post #2


Newbie
*

Group: Members
Posts: 2
Joined: 17-August 07
Member No.: 10,177


Ukraine


Hi!
we have the same core switch and don't have any problems.
try to use older version of tftp32 - I used 2.XX
if u want additional information about ios on my switch and exact version of my tftp - i can answer, but i need to check them - i dont remeber.
regards.
Go to the top of the page
 
+Quote Post
Peter H
post Oct 3 2007, 08:07 PM
Post #3


Newbie
*

Group: Members
Posts: 2
Joined: 17-August 07
Member No.: 10,168


United Kingdom


QUOTE(TopBrick @ Aug 17 2007, 11:13 PM) *
Hi!
we have the same core switch and don't have any problems.
try to use older version of tftp32 - I used 2.XX
if u want additional information about ios on my switch and exact version of my tftp - i can answer, but i need to check them - i dont remeber.
regards.


Thanks TB - our local friendly consultant raised a TAC call with Cisco and it seems something in the UDP config is the issue but I haven't had a full explanation yet.

I know it's udp related cos soemone left UDP packet debugging on the core and then when a vc first thing in the morning the network slowed to a crawl. Took us an hour to notice!

Go to the top of the page
 
+Quote Post
Jonathan Hall
post Oct 9 2007, 09:59 AM
Post #4


Newbie
*

Group: Members
Posts: 1
Joined: 9-October 07
Member No.: 11,149


United Kingdom


QUOTE(Peter H @ Oct 3 2007, 09:07 PM) *
Thanks TB - our local friendly consultant raised a TAC call with Cisco and it seems something in the UDP config is the issue but I haven't had a full explanation yet.

I know it's udp related cos soemone left UDP packet debugging on the core and then when a vc first thing in the morning the network slowed to a crawl. Took us an hour to notice!


We've just started using tftpd32, after we hit the file size issue with Solarwinds, and we're having exactly the same issues on our new Catalyst 6509s with Sup720s running IOS 12.2(xx)SX train.

As suggested we've tried v2.88 as well as v3.23. Both have the same problem.

If you find a fix/work around for this please let us know.
Go to the top of the page
 
+Quote Post
« Next Oldest · Tftpd32 · Next Newest »
 

Fast ReplyReply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

Collapse

> Similar Topics

  Topic Replies Topic Starter Views Last Action
No New Posts TFTPD32 stops responding
3 kryten 1,076 30th August 2007 - 07:27 AM
Last post by: kryten
No New Posts TFTPD32 with Cisco Phones (Option 150)
0 strangel 1,500 27th April 2007 - 09:33 PM
Last post by: strangel
No New Posts TFTPD32 forum added!
0 Nuno Brito 837 27th March 2007 - 08:32 PM
Last post by: Nuno Brito


 

Display Mode: Standard · Switch to: Linear+ · Switch to: Outline

Track this topic · Email this topic · Print this topic · Subscribe to this forum

- Lo-Fi Version Time is now: 13th October 2007 - 04:15 AM

MKPortal ©2003-2006 mkportal.it